Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Agent picking chronyd

Agent picking chronyd

Hello, We have disabled chronyd in all hosts and NTP is enabled  on all hosts.

I get an clock offset error in Cloudera Manager on one  host. When I check the agent logs it gives

 

File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.14.4-py2
.7.egg/cmf/subprocess_timeout.py", line 94, in subprocess_with_timeout
raise Exception("timeout with args %s" % args)
Exception: timeout with args ['chronyc', 'sources']
[22/May/2019 10:24:12 +0000] 3179 Monitor-HostMonitor throttling_logger ERROR
(29 skipped) chronyc: chronyc sources: not synchronized to any server
[22/May/2019 10:25:46 +0000] 3179 MainThread heartbeat_tracker INFO HB stats
(seconds): num:40 LIFE_MIN:0.01 min:0.01 mean:0.01 max:0.01 LIFE_MAX:0.10
[22/May/2019 10:35:46 +0000] 3179 MainThread heartbeat_tracker INFO HB stats
(seconds): num:40 LIFE_MIN:0.01 min:0.01 mean:0.01 max:0.01 LIFE_MAX:0.10
[22/May/2019 10:37:37 +0000] 3179 CP Server Thread-9 _cplogging INFO 10.203
.51.158 - - [22/May/2019:10:37:37] "GET /heartbeat HTTP/1.1" 200 2 "" "NING/1.0"

 

 

 

I followed these steps to troubleshoot :

1. cloudera-scm-agent]# ntpstat
synchronised to NTP server (server name) at stratum 3
time correct to within 60 ms
polling server every 256 s

 

2.  cloudera-scm-agent]# systemctl status chronyd
● chronyd.service - NTP client/server
Loaded: loaded (/usr/lib/systemd/system/chronyd.service; disabled; vendor preset: enabled)
Active: inactive (dead)
Docs: man:chronyd(8)
man:chrony.conf(5)

3. ntpq -np

There is a line starts with * and that is the NTP server synchronized to, NTP service and deamon is also running

 

Any idea why the agent still picks up chronyd even after disabling it completely? this happens only on one host though

3 REPLIES 3

Re: Agent picking chronyd

@bgooley Hello, please refer this new thread. I tried those steps but  the issue persist

Re: Agent picking chronyd

Super Guru

@BiggieSmalls , 

 

Thanks for starting the new thread.

As I mentioned in the other thread, the agent will run the following to detect if chronyd is running so it can use it if it is running:

 

  # pidof chronyd

 

If there is a chronyd process running, then the above command will return the PID of that process.

I would run the "pidof chronyd" command and see what the output is.  If there is a PID returned, use "ps aux |grep <pid>" to find out what that process actually is.  If nothing is returned, try restarting the agent to make sure it must check for chronyd again:

 

  # systemctl restart cloudera-scm-agent

 

I am pretty confident the above steps should help.

 

Highlighted

Re: Agent picking chronyd

Hey , Just found the issue that we had a recent reboot and chronyd, even though it is disabled at commandline but still it was running as process in background which should not happen ideally. So, agent is picking chronyd. Thanks for the insight.

Don't have an account?
Coming from Hortonworks? Activate your account here