Support Questions
Find answers, ask questions, and share your expertise
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

All SQLs are failing in Hue Impala editor


All SQLs are failing in Hue Impala editor

New Contributor

Hi Team,


I am a newbie in Hadoop. I started today with the tutorial of cloudera. I have quickstart vm 5.4.2.


I imported MYSQL retail db tables into HDFS along with schema files. I created external tables in Impala query editor and then applied show tables; command. I can see those tables and also at the left hand side of the editor, I can see these tablenames.


Problem is whenever I am writing any SQL involving these tables, it is timed out. Then from recent query tab, I can see below error.



select p.product_id, p.product_name
from products p
order by p.product_id desc
limit 10;

Error after few minutes as seen in the result column:

a2b_base64() argument 1 must be string or read-only character buffer, not None


Can anybody please help? I am not even able to drop these tables and recreate.


Re: All SQLs are failing in Hue Impala editor

New Contributor



I am really not sure what happened but when I restarted Hue and Impala editor, tried to read sample data from metastore, from that point my SQLs started providing correct result.


Looks like it is solved now :)