Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ambari 2.6.2.2 / HDP 2.6.5 / CentOS 7.5 -- unable to successfully deploy cluster due to repository errors

Highlighted

Ambari 2.6.2.2 / HDP 2.6.5 / CentOS 7.5 -- unable to successfully deploy cluster due to repository errors

New Contributor

Hi,

We have 7 nodes (3 master / 4 worker) that we're trying to deploy a cluster to. We've fought through a couple issues:

1. SSL handshake back to our ambari server was resolved at https://community.hortonworks.com/questions/145/openssl-error-upon-host-registration.html

2. We've had various versions of the HST issue described here: https://community.hortonworks.com/content/supportkb/49033/smartsense-installation-failed.html

Our current issue is that, despite having the nodes seemingly having the correct repo information, they're not pulling packages from the repos and we're getting various versions of output like this:

stderr: /var/lib/ambari-agent/data/errors-1430.txt
2018-09-25 11:09:26,473 - The 'accumulo-master' component did not advertise a version. This may indicate a problem with the component packaging. However, the stack-select tool was able to report a single version installed (2.6.5.0-292). This is the version that will be reported.
Command aborted. Reason: 'Server considered task failed and automatically aborted it'

2018-09-25 11:09:26,117 - Package['unzip'] {'retry_on_repo_unavailability': False, 'retry_count': 5}

2018-09-25 11:09:26,276 - Skipping installation of existing package unzip
2018-09-25 11:09:26,277 - Package['curl'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2018-09-25 11:09:26,294 - Skipping installation of existing package curl
2018-09-25 11:09:26,294 - Package['hdp-select'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2018-09-25 11:09:26,312 - Skipping installation of existing package hdp-select
2018-09-25 11:09:26,429 - call[('ambari-python-wrap', u'/usr/bin/hdp-select', 'versions')] {}
2018-09-25 11:09:26,472 - call returned (0, '2.6.5.0-292')
2018-09-25 11:09:26,473 - The 'accumulo-master' component did not advertise a version. This may indicate a problem with the component packaging. However, the stack-select tool was able to report a single version installed (2.6.5.0-292). This is the version that will be reported.
2018-09-25 11:09:26,918 - Command repositories: HDP-2.6-repo-51, HDP-2.6-GPL-repo-51, HDP-UTILS-1.1.0.22-repo-51
2018-09-25 11:09:26,918 - Applicable repositories: HDP-2.6-repo-51, HDP-2.6-GPL-repo-51, HDP-UTILS-1.1.0.22-repo-51
2018-09-25 11:09:26,922 - Looking for matching packages in the following repositories: HDP-2.6-repo-51, HDP-2.6-GPL-repo-51, HDP-UTILS-1.1.0.22-repo-51
Command aborted. Reason: 'Server considered task failed and automatically aborted it'

-BUT- some packages are clearly installing... here's the yum.log output from the node that the above example errors were copied out of:

Sep 25 11:09:45 Installed: hdp-select-2.6.5.0-292.noarch Sep 25 11:10:35 Installed: zookeeper_2_6_5_0_292-3.4.6.2.6.5.0-292.noarch

Sep 25 11:10:41 Installed: atlas-metadata_2_6_5_0_292-storm-plugin-0.8.0.2.6.5.0-292.noarch

Sep 25 11:10:48 Installed: ranger_2_6_5_0_292-storm-plugin-0.7.0.2.6.5.0-292.x86_64

Sep 25 11:11:22 Installed: storm_2_6_5_0_292-1.1.0.2.6.5.0-292.x86_64

-----------

We're presently trying to install all available features to the cluster. Has anyone encountered anything like this?

Thank you!

2 REPLIES 2

Re: Ambari 2.6.2.2 / HDP 2.6.5 / CentOS 7.5 -- unable to successfully deploy cluster due to repository errors

New Contributor

It would probably help if I posted repo contents...

[root@node02 ~]# cat /etc/yum.repos.d/ambari-hdp-51.repo

[HDP-2.6-repo-51]

name=HDP-2.6-repo-51

baseurl=http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.6.5.0

path=/ enabled=1 gpgcheck=0

[HDP-2.6-GPL-repo-51]

name=HDP-2.6-GPL-repo-51

baseurl=http://public-repo-1.hortonworks.com/HDP-GPL/centos7/2.x/updates/2.6.5.0

path=/ enabled=1

gpgcheck=0

[HDP-UTILS-1.1.0.22-repo-51]

name=HDP-UTILS-1.1.0.22-repo-51

baseurl=http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.22/repos/centos7

path=/

enabled=1

gpgcheck=0

Re: Ambari 2.6.2.2 / HDP 2.6.5 / CentOS 7.5 -- unable to successfully deploy cluster due to repository errors

New Contributor

As an update, we attempted an upgrade to Ambari 2.7.0 with HDP 3 and, as an example error, got the following (same error type as originally posted with previous version):

2018-09-27 11:03:12,081 - The 'hbase-master' component did not advertise a version. This may indicate a problem with the component packaging. However, the stack-select tool was able to report a single version installed (2.6.5.0-292). This is the version that will be reported. Command aborted. Reason: 'Server considered task failed and automatically aborted it'

If I go to a command prompt on an individual node, I'm able to do "yum install" of any component I choose. The issue seems to be communication between nodes and Ambari -- something is causing the nodes to report failure when there really isn't one, so we can't proceed.