Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ambari Blueprint 2.6 HDP stack 2.6

Solved Go to solution

Ambari Blueprint 2.6 HDP stack 2.6

Expert Contributor

Hi

After installation of a cluster using the Ambari UI i exported the blueprint.

Then attempted to re-install the same cluster using the blueprint however i receive this error when apply the cluster template.

"status" : 400,
  "message" : "Stack information should be provided when creating a cluster"

To be sure the blueprint contains the following information

  "Blueprints" : {
    "blueprint_name" : "cluster-blueprint",
    "stack_name" : "HDP",
    "stack_version" : "2.6"
  }

How do we provide this information ?

I see that this commit causes this . What is the workaround ?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Ambari Blueprint 2.6 HDP stack 2.6

Super Mentor

@Anshuman Mehta

From Ambari 2.6 onwards there is a slight change. Can you please refer to the following link:

Behavioral Change 2.6.0: https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.0.0/bk_ambari-release-notes/content/ambari_reln...

2 REPLIES 2

Re: Ambari Blueprint 2.6 HDP stack 2.6

Super Mentor

@Anshuman Mehta

From Ambari 2.6 onwards there is a slight change. Can you please refer to the following link:

Behavioral Change 2.6.0: https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.0.0/bk_ambari-release-notes/content/ambari_reln...

Re: Ambari Blueprint 2.6 HDP stack 2.6

Expert Contributor

@Jay Kumar SenSharma

it seems that my console had kind of eaten up the "-" from the "-d@" curl command.

... please disregard .. will update once figured out ..

This does not work although it did seem to. Starting from a clean environment leads me to the same state. i.e

  1. Register the VDF (local)
  2. Register the Blueprint with the stack_name and stack_version
  3. Initiate a cluster deployment using a cluster template using the repository_version_id or repository_version

Still yields the same error

"message" : "Stack information should be provided when creating a cluster"

My previous work-around was to restart the ambari-agent nodes on each node and that seemed to work. But that doesnt seem to work as of today.

From the ambar-server log

02 Jan 2018 20:57:17,595 ERROR [ambari-client-thread-85] BaseManagementHandler:67 - Bad request received: Stack information should be provided when creating a cluster<br>
Don't have an account?
Coming from Hortonworks? Activate your account here