Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ambari Login Doesn't works (windows 10)

Solved Go to solution
Highlighted

Ambari Login Doesn't works (windows 10)

New Contributor

Hello, the setup is working properly except when logging into Ambari. The following screenshot is the webpage that shows up when I click on "launch dashboard". All my pop ups are disabled. I'm using HDP-2.5 sandbox.

Thanks for your help.

56384-screenshot-4.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Ambari Login Doesn't works (windows 10)

Super Mentor

@Diego Gimenez

On Windows you can use the following commadn to list the ports are in use and by which process. Please see this for more details: https://stackoverflow.com/questions/48198/how-can-you-find-out-which-process-is-listening-on-a-port-...

C:\> netstat -a -b

Please check which process is using port 8080 and then kill it.

Also please make sure to Clear the Browser Cache (or run the browser in Incognito mode / Private mode)...just to ensure that browser is not showing cached page and directly reaching to the actual server to get the response.

.

6 REPLIES 6

Re: Ambari Login Doesn't works (windows 10)

@Diego Gimenez

Heya,

Looks like you have another service on your machine that's taking up the 8080 port, so requests aren't actually reaching Ambari.

You can either stop the EDB Postgres service on your machine if it's not in use, or if you need to keep it on you can make a couple of changes to get the Ambari UI to show up via another port.

What VM are you running the sandbox on (VirtualBox/VMware)?

Re: Ambari Login Doesn't works (windows 10)

New Contributor

Thanks for the fast answer @Edgar Orendain!

I am using Virtual Box. I have Postgres installed in my local machines as well.

How may enable and disable EDB postgres service?

Thank you very much!

Re: Ambari Login Doesn't works (windows 10)

Super Mentor

@Diego Gimenez

Looks like on your Windows 10 you are running EDB Postgres Service which is also using port 8080 hence when you are trying to access the Ambari Serevr UI on port 8080 that time you are getting the EDB Postgres UI.

On Windows you can Enable OR Disable services as following:

Open Windows Services as following:

In the command prompt enter "services.msc" to open the "Services Manager". Here you will be able to see list of services that are running. Please click on Stop (and change the "Start Type = "Manual") button on the EDB Postgres service and then it should not run.

Please see "How to start , stop and disable Services in windows 10"

If needed that try to restart the HDP Sandbox afterwards.

Re: Ambari Login Doesn't works (windows 10)

New Contributor

Thank you very much @Jay Kumar SenSharma

Despite I have stopped and changed the start type of several services I am continuing having the same problem.

These are the services that I stopped and changed to manual:

  • EnterpriseDB ApacheHTTPD
  • Enterprise App Management service
  • Postgresql-x64-10 - PostgreSQL Server 10

I have restarted HDP Sandbox and my computer as well and I still have the same error.

I don't know if there is any other service that I am not aware of that should be stopped.

Thank you very much for your help!!

Re: Ambari Login Doesn't works (windows 10)

Super Mentor

@Diego Gimenez

On Windows you can use the following commadn to list the ports are in use and by which process. Please see this for more details: https://stackoverflow.com/questions/48198/how-can-you-find-out-which-process-is-listening-on-a-port-...

C:\> netstat -a -b

Please check which process is using port 8080 and then kill it.

Also please make sure to Clear the Browser Cache (or run the browser in Incognito mode / Private mode)...just to ensure that browser is not showing cached page and directly reaching to the actual server to get the response.

.

Re: Ambari Login Doesn't works (windows 10)

New Contributor

@Jay Kumar SenSharma

The problem was the cache.

Thank you so much for the help!