Support Questions
Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

Ambari Metric Service (ams) unable to open through hostname:6188

Hi ,
i am trying to add service Ambari metric Service for hdp2.6.3.
- got 1 alert PFA. hbase-alert.png

- i was able to start AMS service

-so i tried to acess http:

got below logs from "/var/log/ambari-metrics-monitor/ambari-metrics-monitor.out"

2018-03-05 16:05:55,395 [INFO] - Calculated collector shard based on hostname : 2018-03-05 16:05:55,399 [WARNING] - Error sending metrics to server. [Errno 111] Connection refused 2018-03-05 16:05:55,399 [WARNING] - Retrying after 5 ... 2018-03-05 16:06:00,400 [WARNING] - Error sending metrics to server. [Errno 111] Connection refused 2018-03-05 16:06:00,401 [WARNING] - Retrying after 5 ... 2018-03-05 16:06:05,403 [WARNING] - Error sending metrics to server. [Errno 111] Connection refused 2018-03-05 16:06:05,403 [WARNING] - Retrying after 5 ... 2018-03-05 16:06:10,405 [WARNING] - Metric collector host was blacklisted. 2018-03-05 16:06:10,405 [INFO] - No valid collectors found...

- got few refernces fro whitelisting

but it is for whitelisting apps not the hosts or ip address.

Thanks ,



Can you try whitelisting all the services you have installed in the node? Since this is a Sandbox, ensure all services like Datanode, Namenode etc are whitelisted.

Its working for me . followed below steps:-

- add port for sandbox container 6188. follow document
- once the port is added. sandbox is up and running. login as admin/admin through ambari UI.
- Click on Actions from All services -> click on Add service.
- select "Ambari Metrics Service"
- In configuration Setting change the heapsize as per the configuration in below reference.
- after deploying ambari metrics service succesfully.
- from service start Ambari Infra-which will start solr
- from services start atlas- there is some dependancy of solr- atlas-hbase-ams
- click on Ambari Metrics- start.
- if still not working then follow :-
- API cmds to retrieve the data from ams
- follow document for more details