Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ambari add service stuck "Add Service Wizard in Progress"

Solved Go to solution

Ambari add service stuck "Add Service Wizard in Progress"

New Contributor

Sandbox 2.5 HDP 2.5 Ambari: 2.4.0.0

This morning we opened up the add service menu to see what was available. Then closed the browser (with the service window open - a service may have been selected but never hit next to actually start the installation). Now the add service menu is gone (See image below) and a status is posted across the top stating that "Add Service Wizard in Progress". We did not try to install (see image below).

8850-screen-shot-2016-10-24-at-30858-pm.png

8861-screen-shot-2016-10-24-at-30845-pm.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Ambari add service stuck "Add Service Wizard in Progress"

New Contributor

Hi @James Benson, did you manage to sort this out? I'm experiencing the same issue and have not been able to solve it so far

7 REPLIES 7

Re: Ambari add service stuck "Add Service Wizard in Progress"

@James Benson Can you try to restart ambari server $ambari-server restart and check if the add service tab is back in place?

Re: Ambari add service stuck "Add Service Wizard in Progress"

New Contributor

Sorry, I should have said that. I did try an $ambari-server restart and no change. That was actually the first thing I did. I also looked in the server logs and didn't see anything interesting there, but wasn't 100% what to look for either. (Nothing significant under ERROR)

Re: Ambari add service stuck "Add Service Wizard in Progress"

New Contributor

Hi @James Benson, did you manage to sort this out? I'm experiencing the same issue and have not been able to solve it so far

Re: Ambari add service stuck "Add Service Wizard in Progress"

New Contributor

Ok, I was able resolve the problem this morning.

When I was seeing the problem in Ambari I was logged in as 'admin' user. It turns out that there was another user account which opened the 'add service' dialog (but had not begun any installation) and closed the browser window without exiting out of the dialog. By logging into that second account and closing the dialog I was able to interact with the cluster normally again.

It would've been nice if the system automatically cancelled the 'add service' dialog when the second users session had expired, or at least listed which user had initiated the action. As no installation had begun it just sat there waiting for user input for days, while also locking all other users out from making changes.

Re: Ambari add service stuck "Add Service Wizard in Progress"

New Contributor

It would be nice if there was some sort of way to figure out which user is logged into ambari and had that wizard open. Do you know of any way to find out which user was logged?

Re: Ambari add service stuck "Add Service Wizard in Progress"

New Contributor

@Jeffery Williams, yes, that's how we solved it too. Sorry, lost track of the conversation. @Jose Bonilla, no way that I know of.

Re: Ambari add service stuck "Add Service Wizard in Progress"

pls do check - https://community.hortonworks.com/articles/67359/ambari-ui-shows-move-master-wizard-in-progress.html

We cannot find the user who left the wizard untouched.

Don't have an account?
Coming from Hortonworks? Activate your account here