Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ambari agent running with no issue then suddenly not running

Ambari agent running with no issue then suddenly not running

New Contributor

Amabri agent on 1 node wont start.. Please help

Thank you in advanc

compute.internal, serverOsType=amazon6, agentOsType=amazon2018 INFO 2018-07-10 23:00:43,077 Controller.py:516 - Registration response from ambari-server.us-west-2.compute.internal was FAILED INFO 2018-07-10 23:00:43,077 Controller.py:531 - Registration response from %s didn't contain 'response' as a key INFO 2018-07-10 23:00:43,077 Controller.py:503 - Finished heartbeating and registering cycle INFO 2018-07-10 23:00:43,077 Controller.py:509 - Controller thread has successfully finished INFO 2018-07-10 23:00:44,930 ExitHelper.py:56 - Performing cleanup before exiting... INFO 2018-07-10 23:00:44,930 threadpool.py:120 - Shutting down thread pool INFO 2018-07-10 23:00:44,947 scheduler.py:606 - Scheduler has been shut down INFO 2018-07-10 23:00:44,947 threadpool.py:58 - Started thread pool with 3 core threads and 20 maximum threads INFO 2018-07-10 23:00:44,947 AlertSchedulerHandler.py:185 - [AlertScheduler] Stopped the alert scheduler. INFO 2018-07-10 23:00:44,947 threadpool.py:120 - Shutting down thread pool INFO 2018-07-10 23:00:44,947 ExitHelper.py:70 - Cleanup finished, exiting with code:0 [root@ip-10-10-10-130 ~]#

79438-agent.jpg

7 REPLIES 7

Re: Ambari agent running with no issue then suddenly not running

Cloudera Employee

The issue here is "Cannot register host with not supported os type"

"serverOsType=amazon6, agentOsType=amazon2018"

The /usr/lib/ambari-server/lib/ambari_commons/resources/os_family.json will have the supported OS versions, seems amazon2018 is still not validated.

Re: Ambari agent running with no issue then suddenly not running

New Contributor

Hi do i need to add the agentOsType=amazon2018 in the os_family.json?

Re: Ambari agent running with no issue then suddenly not running

Cloudera Employee

You can try adding it in the aliases field, As suggested this is yet not validated.

},

"aliases": {

"amazon2015": "amazon6",

"amazon2016": "amazon6",

"amazon2017": "amazon6",

"suse11sp3": "suse11"

}

Highlighted

Re: Ambari agent running with no issue then suddenly not running

New Contributor

Hi still not working.

Re: Ambari agent running with no issue then suddenly not running

Mentor

@Osmaro Gariando

Can you also provide your multinode cluster nodes OS differences version of HDP / Ambari versions

Re: Ambari agent running with no issue then suddenly not running

New Contributor

Hi Geoffrey

all cluster has OS is Amazon Linux AMI release 2018.03 there was no differences on HDP/Ambari version

I have build this cluster using cloudbreak 2.6 and no issue within 6months and just recently 1 node have problem.

StackHDP-2.6
NameHDP-2.6.4.5-2
Version2.6.4.5-2

Re: Ambari agent running with no issue then suddenly not running

New Contributor

Hi,


I'm facing the same issue. I tried editing the aliases field but it is not working also.
Has anyone found a solution???


Thanks in advance