Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ambari failed to install services

Solved Go to solution

Re: Ambari failed to install services

New Contributor

Hi Lucas,

I believe you are using the wrong repo or you have a missing repo. Generally there are two repos one for HDP and the other is HDP-Utils. can you paste the contents of ambari-hdp-2.repo

Highlighted

Re: Ambari failed to install services

Expert Contributor

@Zill Silveira

For the new version 2.6.4.0, it downloads ambari-hdp-1.repo file which got 3 urls for hdp, jenkins key and hdp utils. I have posted more details with the issue in the below link. That got all details. Have a look.

https://community.hortonworks.com/questions/172034/hdp-2640-cluster-creation-is-getting-failed-due-t...

Re: Ambari failed to install services

Cloudera Employee

For Error "Cannot match packagefor regexp name oozie_${stack_version}.Available packages:['accumulo','accumulo-conf-standalone','accumulo-source','accumulo_2_6_3_0_235-conf-"

Run below in the node where Oozie is being installed.

yum list installed | grep oozie -- check if the output has proper HDP repo @HDP-2.6-repo-1 listed. If it just says "installed" then run below

yum-complete-transaction -- this should complete outstanding transactions. Then remove oozie from the node.

yum remove oozie -- check if there is any version listed due to repo issues prior to removing. Then goto Ambari and try Re-install. It worked for me. Also should clear Ambari Component version alert.

Re: Ambari failed to install services

New Contributor

@ln chari can we give this a try in your setup? The OP has reverted and installed 2.6.2.0 because 2.6.4.0 didn't work.

Re: Ambari failed to install services

Expert Contributor

Same happened to me When I rearranged the hdf.repo file in /etc/yum.repos.d/ Ambari succeeded to start services.

Re: Ambari failed to install services

New Contributor

Hi Erkan, can you please provide more details on how your resolved the issue.

I am also facing same issue while installing HDP 2.6.4

Thanks in advance.

Re: Ambari failed to install services

New Contributor

Hi Erkan,

Can you please provide more details on how you resolved the issue.

Iam facing same issue while installing HDP 2.6.4

Thanks in advance.

Re: Ambari failed to install services

New Contributor

Hi Erkan, Could you please advise how this was resolved i am getting the same error with Ambari 2.6.1.5 and HDF 3.1