Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ambari installation keep warning that "ntpd" is not installed on hosts.

Ambari installation keep warning that "ntpd" is not installed on hosts.

New Contributor

I am trying to install HDP 2.5 on a 15 node cluster using Ambari. I made sure that all the nodes (including Ambari server node) running 'ntpd' using

systemctl enable ntpd

But during the installation,Ambari keep warning that all the hosts missing ntpd

ntpd Not running on 11 hosts.

How to fix this ?

To access Ambari server from my local machine, I have to use http proxy because the two networks are separated.Do I have to configure special setting in this case?

Can I ignore this warning and continue the instalattion since the ntpd service is acutally running ?

5 REPLIES 5

Re: Ambari installation keep warning that "ntpd" is not installed on hosts.

Expert Contributor

Hi @Ashika Umagiliya,

You need to start ntpd as well with: systemctl start ntpd

/Best regards, Mats

Re: Ambari installation keep warning that "ntpd" is not installed on hosts.

New Contributor

yes, thats what i did on all the nodes.

and "systemctl is-enabled ntpd" showed that ntpd is running.

Re: Ambari installation keep warning that "ntpd" is not installed on hosts.

New Contributor

sorry, i missed the "start" part

Re: Ambari installation keep warning that "ntpd" is not installed on hosts.

Mentor

@Ashika Umagiliya

To be able to install Ambari successfully all the servers in the cluster have to be in sync. The NTPD should be running

You should have installed pdsh for easier cluster management

Configure the NTPD services

# yum install ntp ntpdate 

Turn on the ntpd service:

# chkconfig ntpd on 

Synchronize the system clock with 0.pool.ntp.org server

# ntpdate pool.ntp.org 

Check the NTPD services configure it start at system boot

# chkconfig --list ntpd

Hope that helps

Highlighted

Re: Ambari installation keep warning that "ntpd" is not installed on hosts.

New Contributor

@umangapdn I discovered (assuming you're using Centos 7) that you need to turn off a conflicting time service off -> chrony

sudo systemctl disable chronyd
Don't have an account?
Coming from Hortonworks? Activate your account here