Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Ambari metrics widget (custom) for service cannot be added to service dashboard

avatar
Explorer

I'm running a NIFI cluster (1 NCM and 3 nodes) with ambari. I have added metrics and widget definition to it . Data are collected (present in DB) but the widget are not added to the service dashboard. When trying to add them (they are visible in the "browse widgets") nothing happens . On the service dashboard ,I cannot create any widget either.

1 ACCEPTED SOLUTION

avatar
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
7 REPLIES 7

avatar
Master Mentor

@Daniel Hendrix

What did you use to integrate nifi with ambari ?

Official repo or a repo from github?

avatar
Master Mentor

https://issues.apache.org/jira/plugins/servlet/mobile#issue/AMBARI-9156

I suggest to wait for official version of repo.

avatar
Master Mentor
@Daniel Vielvoye

it's not yet supported but in general you can refer to this api to add metrics https://cwiki.apache.org/confluence/display/AMBARI/Metrics+Collector+API+Specification

avatar
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Contributor

avatar
Explorer

on general : I follow the tuto from http://bryanbende.com/development/2015/07/31/ambari-metrics-part2-metrics-collector/ and install guidelines (http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.0.0/bk_Installing_HDP_AMB/content/index.html)

- Ambari metrics is up and working correctly to monitor systems and HDFS usage.

- I did install the repo from Horton (HDP with ambari 2.2) for Nifi I started with the repo from Ali and modified it to create the NCM node and the slaves nodes.

- I also used the AmbariReport in Nifi (I think work from Bryan in the Nifi service provided by Ali)

-I checked with phoenix :data are present in database

avatar
Explorer

A quick update : I did reinstall Ambari completely and also re-check all my config files : at least now the add widget is working but still does not display data (while phoenix shows data in hbase) I suspect something with the fact that I collect data on the 3 NiFi nodes while I try to display them for the whole service ...