Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ambari "Add Service Wizard" - everything is greyed out, can't add any Service. Is there any fix or am I doing something wrong?

Highlighted

Ambari "Add Service Wizard" - everything is greyed out, can't add any Service. Is there any fix or am I doing something wrong?

New Contributor

Dear All,

I wanted to install Storm onto a Ambari managed cluster (HDP 3.1). Following the instruction I came to the "Add Service Wizard" by clicking at the '...' besides the "Services" menupoint on the left and chose "+Add Service". On the Wizard I am supposed to select the file system, and then the service wanted. Now the issue is that I actually can't change anything, all the options are greyed out, and I cannot check or uncheck them. At the very bottom, the button "Next->" is also greyed out. And when I hover my mouse pointer over it, my mouse icon turns to be a banning sign. I make it clear, I attached a screenshot.

Is there anything done wrong? How can I fix it? I am grateful to get any help! Thanks in advance!

99447-unbenannt3.png

4 REPLIES 4

Re: Ambari "Add Service Wizard" - everything is greyed out, can't add any Service. Is there any fix or am I doing something wrong?

Mentor

@Qianhao Lu

The procedure you pointed to is correct. Did you by any chance create a new Ambari user? This can happen when your user doesn't have admin privileges that's my first guess, if that isn't the case can you restart the Ambari server and ambari-agent and retry?

Re: Ambari "Add Service Wizard" - everything is greyed out, can't add any Service. Is there any fix or am I doing something wrong?

Mentor

@Qianhao Lu

Any updates do you still need help?

Re: Ambari "Add Service Wizard" - everything is greyed out, can't add any Service. Is there any fix or am I doing something wrong?

Mentor

@Qianhao Lu

Any updates do you still need help?

Re: Ambari "Add Service Wizard" - everything is greyed out, can't add any Service. Is there any fix or am I doing something wrong?

New Contributor

I have a similar problem. I am trying to add an additional solr infra service but the only button I am allowed to select is for "log search". I have all other services installed as part of the initial setup but now they are all greyed out. As per hortonworks documentation I should be able to add a solr infra instance from add service. Any help here would be greatly appreciated. I am using the "admin" user and I seem to have all the necessary privileges.