Support Questions
Find answers, ask questions, and share your expertise

Ambari server up and running... but cant access hue

I heard that by starting the ambari server we can access hue automatically. but i cant access it from the given url : http://127.0.0.1:8888/. what should i do to get into hue?? please help me.

Thanking in advance

15 REPLIES 15

@Roopa Raphael

Pls try http://127.0.0.1:8000/

username password - hue/1111

i tried the same but still cant connect to it. its showing "unable to connect"

Can you check if the HUE process is running using below commands -

1. Check hue service status using below command -

[root@sandbox ~]# /etc/init.d/hue status
supervisor (pid  5288) is running...
[root@sandbox ~]# 

2.Can you check if the HUE process is running using below commands -

$ netstat -taupen |grep 8000

[root@sandbox ~]# netstat -taupen |grep 8000
tcp        0      0 0.0.0.0:8000                0.0.0.0:*                   LISTEN      1003       35244      5297/python2.6      

Get the PID from above command, in my case its 5297 -

DO ps on the PID -

[root@sandbox ~]# ps -aef |grep 5297
hue       5297  5288  0 May23 ?        00:01:55 python2.6 /usr/lib/hue/build/env/bin/hue runspawningserver

Make sure the process is running.

2. Login to sandbox cli and try telnet o the hue port - It should display output as shown below -

[root@sandbox ~]# telnet localhost 8000
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.

You might need to install telnet package for this - "yum install -y telnet"

i did as told... but still not possible... the page cannot be accessed.

@Roopa Raphael

Can you paste the output of above commands here.

1. Also pls do #/etc/init.d/hue stop

2. Make sure the process is stopped in #ps -aef |grep hue

3. /etc/init.d/hue start

Pls send this output also.

4699-clip.png

this is it .

i will try out the commands given below and send it .

4700-new-clip.png

this is the output after running the commands given now

also i tried all possible ip addresses that could be and the results are these:

4711-qpr.png

4712-qsr.png

Contributor

you can start hue by

[root@sandbox ~]# /etc/init.d/hue start

If you are unable to access Hue web UI and using HDP 2.4 or higher the below steps might help

1. Shut down your VM.

2. Go to your VM Settings->Network->Adapter 2 and check 'Enable Network Adapter' & Attached to: Bridged Adapter, Name: <wireless adapter>

3. Click Ok and start your VM

4. Start hue as stated above and check your ethernet address using 'ifconfig' command. Should be something like 192.168.xxx.xxx

5. Hue Interface should be accessible at ethernet_address:8000