Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Ambari shows HiveServer2 and Hive Metastore is stopped but they are running

avatar
Explorer

Ambari dashboard is showing HiveServer2 and Hive Metastore is stopped, but from the command line I am able to login into hive cli and hiveserver2 using beeline client also.

I have 6 node cluster in which I have installed hive server in 2 nodes and hive client is installed in all 6 nodes. In node1 ambari dashboard it was showing hiveserver2 and hive metastore is stopped but in node2 it was started.

In node1:

6381-hive-node1.png

In node2:

6382-hive-node2.png

When checked the process id which was available in /var/run/hive/hive.pid and hive-server.pid, they are same.

[node1 ~]$ cd /var/run/hive
[node1.staging.iad hive]$ ls
hive.pid  hive-server.pid
[node1 hive]$ cat hive.pid
14037
[node1 hive]$ cat hive-server.pid
16654
[node1 hive]$ ps -ef| grep 14037
dinesh     564 32124  0 15:10 pts/0    00:00:00 grep 14037
hive     14037     1  0 Aug03 ?        00:01:45 /usr/lib/jvm/jre/bin/java -Xmx1024m -Dhdp.version=2.3.4.0-3485 -Djava.net.preferIPv4Stack=true -Dhdp.version=2.3.4.0-3485 -Dhadoop.log.dir=/var/log/hadoop/hive -Dhadoop.log.file=hadoop.log -Dhadoop.home.dir=/usr/hdp/2.3.4.0-3485/hadoop -Dhadoop.id.str=hive -Dhadoop.root.logger=INFO,console -Djava.library.path=:/usr/hdp/current/hadoop-client/lib/native/Linux-amd64-64:/usr/hdp/2.3.4.0-3485/hadoop/lib/native -Dhadoop.policy.file=hadoop-policy.xml -Djava.net.preferIPv4Stack=true -Xmx1024m -XX:MaxPermSize=512m -Xmx1024m -Dhadoop.security.logger=INFO,NullAppender org.apache.hadoop.util.RunJar /usr/hdp/2.3.4.0-3485/hive/lib/hive-service-1.2.1.2.3.4.0-3485.jar org.apache.hadoop.hive.metastore.HiveMetaStore -hiveconf hive.log.file=hivemetastore.log -hiveconf hive.log.dir=/var/log/hive
[node1 hive]$ ps -ef| grep 16654
dinesh     621 32124  0 15:10 pts/0    00:00:00 grep 16654
hive     16654     1  0 Aug03 ?        00:01:32 /usr/lib/jvm/jre/bin/java -Xmx1024m -Dhdp.version=2.3.4.0-3485 -Djava.net.preferIPv4Stack=true -Dhdp.version=2.3.4.0-3485 -Dhadoop.log.dir=/var/log/hadoop/hive -Dhadoop.log.file=hadoop.log -Dhadoop.home.dir=/usr/hdp/2.3.4.0-3485/hadoop -Dhadoop.id.str=hive -Dhadoop.root.logger=INFO,console -Djava.library.path=:/usr/hdp/current/hadoop-client/lib/native/Linux-amd64-64:/usr/hdp/2.3.4.0-3485/hadoop/lib/native -Dhadoop.policy.file=hadoop-policy.xml -Djava.net.preferIPv4Stack=true -Xmx1024m -XX:MaxPermSize=512m -Xmx512m -Dhadoop.security.logger=INFO,NullAppender org.apache.hadoop.util.RunJar /usr/hdp/2.3.4.0-3485/hive/lib/hive-service-1.2.1.2.3.4.0-3485.jar org.apache.hive.service.server.HiveServer2 --hiveconf hive.aux.jars.path=file:///usr/hdp/current/hive-webhcat/share/hcatalog/hive-hcatalog-core.jar -hiveconf hive.metastore.uris=  -hiveconf hive.log.file=hiveserver2.log -hiveconf hive.log.dir=/var/log/hive
1 ACCEPTED SOLUTION

avatar
Expert Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
11 REPLIES 11

avatar
Master Guru
@Dinesh E

Can you restart Ambari agent and see if helps?

avatar
Explorer
@Kuldeep Kulkarni

Thanks for your reply. Restarted ambari agent, but it doesn't worked out.

avatar
Expert Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Explorer

@sbhat Thanks for you reply.

My issue falls under scenario 2 in that article.

But my hive.pid permission are correct i.e

-rw-r--r-- 1 hive hadoop 6 Aug  4 19:48 hive.pid
-rw-r--r-- 1 hive hadoop 6 Aug  4 19:48 hive-server.pid

And also my procees id's i.e hive-server.pid is matching with the process id when checked using

ps -ef|grep hive

avatar
New Contributor

I have the same problems...Also the tipps didn´t work 😞

avatar
Master Mentor

@Dinesh E

It looks the following services are all in maintenance mode.

Hive Server2
Hive-Metastore
HCat client
Hive Client

Please Turn Off Maintenance Mode and let me know if that worked

avatar
New Contributor

Didn´t work for me 😕

avatar
Super Collaborator

Hi Dinesh,

I had same issue in my env for few months back. In my scenario hive service had started with other user (manually). not with ambari user. kill the procees id and again start the service using ambari console resolved my issue.

avatar
New Contributor

Hi, @subhash parise. Thanks for your answer, but that didn´t worked for me ;-(