Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Ambari shows the Zookeeper quorum as down but Zookeeper is running on all quorum nodes. Can I force Ambari to refresh?

avatar
Super Collaborator

I want to avoid using the REST API to force the status. And even though the service is marked as down, there is no option to run a service check.

1 ACCEPTED SOLUTION

avatar
Super Collaborator
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
11 REPLIES 11

avatar

You could try to restart the Ambari Agents on the Zookeeper nodes or the complete ambari server. What is the current state of the Zookeeper service and host_components? could you check via Rest API <ambari-server>/api/v1/clusters/<clustername>/services/ZOOKEEPER

avatar
Super Collaborator

I pulled the status and everything showed up as started! The Ambari agents and server were then cycled with no change in status.

avatar
Master Mentor
@terry

clear the browser cache and check the status. Please post the log entries from ambari-server.log related to zk.

avatar
Super Collaborator
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Master Mentor

@terry Did you update the pid manually?

avatar

Sounds like this could be a bug..

avatar

The PID-file problem is actually quite common. I have seen this a couple of times already, not just zookeeper-related (e.g. services not starting because of existing pid file with invalid process id, ...).

avatar

@Jonas Straub when you see this behaviour could you make sure to log a ticket with our support team.

FYI, I've asked support to get the ZK issue in a ticket.

avatar

@Olivier Renault I usually do 🙂