Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ambari unable to sign in

Solved Go to solution
Highlighted

Ambari unable to sign in

New Contributor

I have downloaded HDP 2.5 Sandbox for VirtualBox and I am running on my Windows 10 MS Surface. When I bring up the dashboard (using Chrome browser), I am challenged for Ambari credentials (http://127.0.0.1:8080/#/login). I've tried different credentials but always blocked on error: "Unable to sign in. Invalid username/password combination."

I've tried maria_dev/maria_dev many times with no luck, and also raj_ops/raj_ops. I have been successful in using Git Bash to make ssh connection and reset both the root user password and the Ambari admin password (via ambari-admin-password-reset command), but when entering admin with my new password I get the same "unable to sign in" error.

I tried pausing protection of Kaspersky Total Security in case it's a firewall issue of some sort, but this also made no difference.

What is the likely problem here?

Thanks in advance,

Ian

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Ambari unable to sign in

Super Mentor

@Ian Bradshaw

If you want to do SSH inside your HDP sandbox then you will have to use SSH Port 2222 (instead of 22) for SSH.

So when you use Putty then while choosing SSH session you will need to specify SSH port as 2222

SSH Username : root
SSH Password: hadoop

Based on the API call output that you shared it looks like your ambari server is running fine and responding on port 8080.

http://127.0.0.1:8080/api/v1/services/AMBARI/components/AMBARI_SERVER

.

So the same ambari admin credential should work from Browser as well. Have you tried using Incognito Mode (Private Mode) browser (Just to avoid Browser caching issue). Or try a different browser.

8 REPLIES 8

Re: Ambari unable to sign in

Super Mentor

@Ian Bradshaw

By anychance are you running any other service on port 8080?

Can you please try the following API call to see if it is returning results from ambari server? (using oyur own ambari credentials that you have reset)

# curl -iv -u admin:admin -H "X-Requested-By: ambari" -X GET http://127.0.0.1:8080/api/v1/services/AMBARI/components/AMBARI_SERVER

.

Also do we see any error inside the ambari server.log ? If yes then can you please share the output of the above call and the serve log?

Re: Ambari unable to sign in

New Contributor

I'm new to this, how do I access the ambari server log to share its contents with you?

Re: Ambari unable to sign in

Mentor

@Ian Bradshaw

The Ambari server logs ambari-server.log are in /var/log/ambari-server/* you could use WinSCP to copy them to your localhost and attach it to this thread.

Re: Ambari unable to sign in

New Contributor
@Jay Kumar SenSharma

curl command output attached

I'm struggling to retrieve server logs with WinScp. I've tried using to to connect to 127.0.0.1 on port 22 with both root and admin user credentials but it always says connection refused. I expect I'm doing something wrong so if someone can provide me with some idiot guide to retrieving these log files from the sandbox, that'll be appreciated.

Re: Ambari unable to sign in

Super Mentor

@Ian Bradshaw

If you want to do SSH inside your HDP sandbox then you will have to use SSH Port 2222 (instead of 22) for SSH.

So when you use Putty then while choosing SSH session you will need to specify SSH port as 2222

SSH Username : root
SSH Password: hadoop

Based on the API call output that you shared it looks like your ambari server is running fine and responding on port 8080.

http://127.0.0.1:8080/api/v1/services/AMBARI/components/AMBARI_SERVER

.

So the same ambari admin credential should work from Browser as well. Have you tried using Incognito Mode (Private Mode) browser (Just to avoid Browser caching issue). Or try a different browser.

Re: Ambari unable to sign in

New Contributor

Ok, this is an update on my previously posted response that sign in succeeded only when run via Chrome's Incognito Mode.

This morning I ran a session using CCleaner to clear up all the cached browser data and then tried again. To my dismay, the sign in no longer worked even when using Incognito Mode in Chrome. However, I stumbled across the root cause and it was, after all, caused by the security software running on my laptop, which in my case is Kaspersky Total Security.

Kaspersky has a feature called Secure Data Input (aka Secure Keyboard Input), which is basically a browser plugin designed to protect against malicious programs intercepting sensitive data. The solution is to configure an exclusion for the 127.0.0.1 website within the Kaspersky settings. After this, I was successful in logging in via Chrome (any mode). For anyone who may encounter same issue as me in the future, here's how a site exclusion can be configured:

https://support.kaspersky.co.uk/13367#block4

The surprising thing, which threw me off the scent, is that invoking the "Pause Protection" feature for Kaspersky Total Security does not actually stop this secure keyboard input thing from continuing to run.

Many thanks to Jay (@Jay Kumar SenSharma) and Geoffrey (@Geoffrey Shelton Okot) for your helpful responses.

Re: Ambari unable to sign in

New Contributor

@Jay Kumar SenSharma

Many thanks for that advice.

I've retrieved the server log file now and I'm attaching.

I tried logging in as suggested using IE and Edge browsers, both of which produced the same "unable to sign in" errors for maria_dev and admin users. However, I'm very happy to report that when I fired it up in Incognito Mode, the maria_dev login worked just fine! :-)

Strange one, I suppose I need to run a CCleaner session on my browser and try again after that.

ambari-server-log.zip

Re: Ambari unable to sign in

New Contributor

@Jay Kumar SenSharma

Hi I'm having the same issue Ian Bradshaw mentioned in his first post having logging issues with Ambari http://127.0.0.1:8080. I'm using Windows 10 and the username maria_dev and password maria_dev is not working for me. I tried in Chrome, Chrome Incognito, and Internet Explorer. I'm using McAfee ant-virus software on my computer so do I need to change any settings there? Please guide me on how to log into Ambari, I would greatly appreciate your help.

Thanks,

Yujesh