Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Ambari upgrade .

avatar

HI,

I was trying to upgrade the ambari 1.7 from 2.4 and getting error. So I want to know is possible to upgrade the ambari 1.7 to latest version of ambari 2.4.

1 ACCEPTED SOLUTION

avatar
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
7 REPLIES 7

avatar
Super Guru
@Ashnee Sharma

Can you pass the error here.

avatar
Super Guru

what is the the current HDP version and the HDP version you are going to upgrade ? [If you are planing for hdp upgrade also]

avatar

@Sagar Shimpi

Error was:- Ambari Server configured for Embedded Postgres. Confirm you have made a backup of the Ambari Server database [y/n] (y)?

Upgrading database schema

Error output from schema upgrade command:

Exception in thread "main" java.lang.Exception: Unexpected error, upgrade failed

at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.main(SchemaUpgradeHelper.java:370)

Caused by: java.lang.RuntimeException: java.lang.Exception

at org.apache.ambari.server.state.stack.OsFamily.init(OsFamily.java:92)

And yes also planning to upgrade the HDP.

avatar
Super Guru

You need to take care of Java if you are planing for Ambari and HDP upgrade.

avatar

currently using java java -version

"1.7.0_111"

OpenJDK Runtime Environment (rhel-2.6.7.2.el6_8-x86_64 u111-b01)

OpenJDK 64-Bit Server VM (build 24.111-b01, mixed mode)

avatar
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Master Mentor

You must also switch to jdk 7 before you upgrade and upgrade to HDP 2.2.9 before attempting to go to 2.4