Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Apache Ambari : Servic Installation fails for new node

Apache Ambari : Servic Installation fails for new node

New Contributor

I'm trying to add one node to existing Hortonworks sandbox cluster.After registering a node manually to Ambari-server host installing of all components failed in install/start step , So I finished instllation wizard without installing the components and tried to install services and clients manually. The main error I had for most of components and services both in install/start step and manually installation is "No more mirror to try".

resource_management.core.exceptions.Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install 'oozie_2_4_*'' returned 1. Error Downloading Packages:
  oozie_2_4_0_0_169-4.2.0.2.4.0.0-169.el6.noarch: failure: oozie/oozie_2_4_0_0_169-4.2.0.2.4.0.0-169.el6.noarch.rpm from HDP-2.4: [Errno 256] No more mirrors to try.

After many times retrying installation the Datanode And Node Manager and HBase client , HDFS Client and Falcon Client installed successfully but they fail in starting.

Could you please help me? Any body had similar experience? Thanks. I did these for solving the problem:

I've checked the iptables service and it's not running.

I've restart the ambari-server and ambari agent.

The packages are avalilable in repository.

No proxy is set for the connection.

Cleared the Ambari-agent host cache and run yum clear all

I get the same error when I try the command

yum -d 0 -e 0 -y install 'oozie_2_4_*'
3 REPLIES 3
Highlighted

Re: Apache Ambari : Servic Installation fails for new node

Can you please run the following commands on the problematic host and see what output does it show?

yum clean all
yum repolist
yum info oozie_2_4_*
ls  -al  /etc/yum.repos.d 

If you do not find the HDP repo inside the above directory then please download the repo like:

wget -nv http://public-repo-1.hortonworks.com/HDP/centos6/2.x/updates/2.4.0.0/hdp.repo

The try again

Highlighted

Re: Apache Ambari : Servic Installation fails for new node

New Contributor

Thanks @jk for reply.I did the steps , However I could find the hdp.repo I downloaded this .repo and replaced with the hdp.repo in /etc/yum.repo.d this time installation takes longer time and finally fails with the same error.

Highlighted

Re: Apache Ambari : Servic Installation fails for new node

Rising Star

@Sara Rad : This looks like an environment issue rather an ambari specific issue.

Can you check if the following articles helps resolve the issue :

https://access.redhat.com/solutions/203603

Also, you can try :

sudo yum clean metadata

sudo yum clean all
Don't have an account?
Coming from Hortonworks? Activate your account here