Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Apache Knox 1.0.0 with HDP 2.6.4

Apache Knox 1.0.0 with HDP 2.6.4

New Contributor

Hi,

In HDP 3.0 we can see that the release used for Knox is the "1.0.0" and that release support much more UI compare to older releases.

I'm running a cluster with HDP 2.6.4 (knox 0.12.0), is there a way to move my Knox to 1.0.0 without moving all HDP to 3.0 ? and if we can do it, is it supported ?

Tks for you help.
Regards.

S.Ch

3 REPLIES 3

Re: Apache Knox 1.0.0 with HDP 2.6.4

@Sofiane CHIBANI

You can upgrade the Knox manually (non-Ambari) to 1.0.0. However, single component upgrade is not supported/certified by Hortonworks.

Re: Apache Knox 1.0.0 with HDP 2.6.4

New Contributor

Thanks Sindhu,

If I update manually Knox to 1.0.0, that's mean that I'll move to a full manually management/administration of Knox, I can't trust the interaction between Ambari and Kox Anymore, right ?
If this is correct, should I remove completely Knox from Ambari and setup the new release manually ?

Regards.
S.Ch

Highlighted

Re: Apache Knox 1.0.0 with HDP 2.6.4

@Sofiane CHIBANI

The use case of Knox 1.0.0 with HDP 2.6.4 is not tested, so the behaviour with respect to Ambari management and HDP components is unforeseen. You could try managing the Knox manually.

Don't have an account?
Coming from Hortonworks? Activate your account here