Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Apache Metron UI installation Steps in Ubuntu


We have followed the below link step to install Metron 0.3.x and 0.4.1 in Ubuntu 14, we have tried the couple of samples and it is working.

But there is no clear instruction to start Metron mangement, alerts and REST api for ubuntu.

When we start metron alert UI,


We have converted the RPM to DEB using alien command but it is not installing.

Like steps provided for CentOS to access Metron UI, if there is direction for Ubuntu then will be helpful.

./metron-rest start is asking for password but don't know about it.

Please help me on this.





I can start Metron REST, Management and Alerts UI in Ubuntu 14.

Now the problem is Metron Management UI start parser topology not working, it trigger rest API call to start the topology

I have updated all the required properties in rest_application.yml except PARSER_TOPOLOGY_OPTIONS

Example: -k $METRON_KAFKA -z $METRON_ZK -s dummy

In that -k and -z I can mention it but parser dummy should be dynamic and I dont know how to specify that.

Please help me on this


Nov 25, 2017 12:23:49 PM org.apache.catalina.core.StandardWrapperValve invoke SEVERE: Servlet.service() for servlet [dispatcherServlet] in context with path [] threw exception [Request processing failed; nested exception is java.lang.IllegalArgumentException: Could not resolve placeholder 'PARSER_TOPOLOGY_OPTIONS' in string value "${PARSER_TOPOLOGY_OPTIONS}"] with root cause java.lang.IllegalArgumentException: Could not resolve placeholder 'PARSER_TOPOLOGY_OPTIONS' in string value "${PARSER_TOPOLOGY_OPTIONS}" at org.springframework.util.PropertyPlaceholderHelper.parseStringValue( at org.springframework.util.PropertyPlaceholderHelper.replacePlaceholders( at org.springframework.core.env.AbstractPropertyResolver.doResolvePlaceholders( at org.springframework.core.env.AbstractPropertyResolver.resolveRequiredPlaceholders( at org.springframework.core.env.AbstractPropertyResolver.resolveNestedPlaceholders( at org.springframework.core.env.PropertySourcesPropertyResolver.getProperty( at org.springframework.core.env.PropertySourcesPropertyResolver.getProperty( at org.springframework.core.env.AbstractEnvironment.getProperty( at at





The following settings in rest-application.yaml fixed the issue,


script.path: /usr/metron/0.4.1/bin/



script.path: /usr/metron/0.4.1/bin/


script.path: /usr/metron/0.4.1/bin/


Any reason you're not using Ambari to install and manage Metron? I think you could avoid these issues if you did. I believe Ubuntu is supported.



Couple of Reasons,

1. Installing manually helps us to understand Metron internals better and uses of different configurations and scripts involved in it.

2. We have tried using Ambari mpack but in Ubuntu it is not working due to python scripts are using rpm and yum packages to execute commands and few commands are not supported in Ubuntu.

All the installation documents are provided for CentOS except the below one,

FYI attached screenshots shows one more issue while installing Elasticsearch which is available in the mpack,



I would pursue installation through Ambari, you will have a much easier time. Try the suggestion from @asubramanian and if you still run into issues, let us know and we'll help you through it and/or fix bugs if necessary.

Super Collaborator

@Uvaraj Seerangan, can you try with Ambari 2.6 on your Ubuntu? There was a fix that went into Ambari 2.6 which should resolve the install issue with Elasticsearch.

Super Collaborator
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.