Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Apache Zepplelin - HBase interpreter error

Apache Zepplelin - HBase interpreter error

Explorer

Hi,

 

I am facing below issue with HBase interpreter with Apache Zeppelin. Any pointers are appreciated.

 

 

Below are the verisons :

Apache Zeppelin - 0.7.2

Hbase - 1.2

CDH - 5.11.0

 

Below is the error :

org.jruby.exceptions.RaiseException: (NameError) cannot load Java class org.apache.hadoop.hbase.quotas.ThrottleType

at org.jruby.javasupport.JavaUtilities.get_proxy_or_package_under_package(org/jruby/javasupport/JavaUtilities.java:54)
at (Anonymous).method_missing(/builtin/javasupport/java.rb:51)
at (Anonymous).(root)(/opt/cloudera/parcels/CDH-5.11.0-1.cdh5.11.0.p0.34/lib/hbase/lib/ruby/hbase/quotas.rb:23)
at org.jruby.RubyKernel.require(org/jruby/RubyKernel.java:1062)
at (Anonymous).(root)(/opt/cloudera/parcels/CDH-5.11.0-1.cdh5.11.0.p0.34/lib/hbase/lib/ruby/hbase/quotas.rb:24)
at org.jruby.RubyKernel.require(org/jruby/RubyKernel.java:1062)
at (Anonymous).(root)(/opt/cloudera/parcels/CDH-5.11.0-1.cdh5.11.0.p0.34/lib/hbase/lib/ruby/hbase/hbase.rb:98)
at org.jruby.RubyKernel.require(org/jruby/RubyKernel.java:1062)
at (Anonymous).(root)(/opt/cloudera/parcels/CDH-5.11.0-1.cdh5.11.0.p0.34/lib/hbase/lib/ruby/hbase.rb:118)image.png
 
Regards,
Shrilesh

 

 

1 REPLY 1
Highlighted

Re: Apache Zepplelin - HBase interpreter error

Explorer

Hello, do you solved this?

Don't have an account?
Coming from Hortonworks? Activate your account here