Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Apache metron on single node VM metron-config Failure

Highlighted

Re: Apache metron on single node VM metron-config Failure

Explorer

@Mabiin Nam

for me it was due to the wrong version of maven it should be 3.3.9

it seems here that there is a problem with docker

Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.5.0:exec (docker-build) on project metron-debs: Command execution failed. Cannot run program \"docker\" (in directory \"/root/incubator-metron/metron-deployment/packaging/docker/deb-docker\")

I had a problem with docker and I was able to solve it by running this

sudo systemctl start docker
sudo service docker start
sudo usermod -a -G docker myuser
reboot
Highlighted

Re: Apache metron on single node VM metron-config Failure

Explorer

@Mabiin Nam, I haven't encounter this issue before, but @Sohaila Eltanbouly's solution seems to be applicable. It could be that the docker is not enabled to run prior to deploying your Metron.

If that did not work, try to re-clone the Metron git. last I checked, I don't have any 'incubator-metron' anymore.

Highlighted

Re: Apache metron on single node VM metron-config Failure

New Contributor

thanks very munch, I still have issue, although I enabled docker and checked it run.

I try re-install Metron on Ubuntu14. I am following:https://github.com/apache/metron/tree/master/metron-deployment/development/ubuntu14

My OS: Ubuntu16.04 on VMWare Workstation12

Other, I usually failed to connect to the host via ssh when ansible running, Can you give me something recommend to fix it.?

TASK [java_jdk : Install openjdk] **********************************************
fatal: [node1]: UNREACHABLE! => {"changed": false, "msg": "Failed to connect to the host via ssh: ssh: connect to host node1 port 22: No route to host\r\n", "unreachable": true}
	to retry, use: --limit @/root/metron/metron-deployment/development/ubuntu14/ansible/playbook.retry
PLAY RECAP *********************************************************************
node1                      : ok=52   changed=33   unreachable=1    failed=0   	
Highlighted

Re: Apache metron on single node VM metron-config Failure

Explorer

@Mabiin Nam :

Try to run 'vagrant ssh'? If it could not work, try disconeecting and re-connecting your network.

Don't have an account?
Coming from Hortonworks? Activate your account here