Support Questions
Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

Apache metron quick-dev-platform can't complete install with error


*Sorry for my English.

i am really begginer of metron.

i have to create metron evironment on my Mac.(macOS Sierra 10.12.5(16F73))

First, My info

Metron 0.4.1

fatal: Not a git repository (or any of the parent directories): .git



config file =

configured module search path = Default w/o overrides


Vagrant 1.8.1


Python 2.7.11


Apache Maven 3.5.0 (ff8f5e7444045639af65f6095c62210b5713f426; 2017-04-04T04:39:06+09:00)

Maven home: /usr/local/Cellar/maven/3.5.0/libexec

Java version: 1.8.0_144, vendor: Oracle Corporation

Java home: /Library/Java/JavaVirtualMachines/jdk1.8.0_144.jdk/Contents/Home/jre

Default locale: ko_KR, platform encoding: UTF-8

OS name: "mac os x", version: "10.12.5", arch: "x86_64", family: "mac"


Docker version 17.06.1-ce, build 874a737








Darwin choebongjaeui-Mac-mini.local 16.6.0 Darwin Kernel Version 16.6.0: Fri Apr 14 16:21:16 PDT 2017; root:xnu-3789.60.24~6/RELEASE_X86_64 x86_64


Total System Memory = 16384 MB

Processor Model: Intel(R) Core(TM) i5-4308U CPU

Processor Speed: 2.80GHz

Total Physical Processors: 2

Total cores: 2

Disk information:

/dev/disk2 1.9Ti176Gi1.8Ti 9% 2796818 42921704610% /


i tried this guide(

but i face error same link(

1. when i ran the first time


The "Quick Dev" deployment fails to complete deployment successfully for me. Ambari fails to launch the Enrichment topology with this error.

resource_management.core.exceptions.ExecutionFailed: Execution of '/usr/metron/0.3.1/bin/ --mode PUSH -i /usr/metron/0.3.1/config/zookeeper -z node1:2181' returned 127. /bin/bash: /usr/metron/0.3.1/bin/ No such file or directory

2.when i the second time (Ambari restart)

Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/common-services/METRON/0.3.1/package/scripts/", line 84, in <module>
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/", line 280, in execute
  File "/var/lib/ambari-agent/cache/common-services/METRON/0.3.1/package/scripts/", line 80, in restart
  File "/var/lib/ambari-agent/cache/common-services/METRON/0.3.1/package/scripts/", line 179, in restart_enrichment_topology
  File "/var/lib/ambari-agent/cache/common-services/METRON/0.3.1/package/scripts/", line 174, in stop_enrichment_topology
  File "/usr/lib/python2.6/site-packages/resource_management/core/", line 155, in __init__
  File "/usr/lib/python2.6/site-packages/resource_management/core/", line 160, in run
    self.run_action(resource, action)
  File "/usr/lib/python2.6/site-packages/resource_management/core/", line 124, in run_action
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/", line 273, in action_run
    tries=self.resource.tries, try_sleep=self.resource.try_sleep)
  File "/usr/lib/python2.6/site-packages/resource_management/core/", line 70, in inner
    result = function(command, **kwargs)
  File "/usr/lib/python2.6/site-packages/resource_management/core/", line 92, in checked_call
    tries=tries, try_sleep=try_sleep)
  File "/usr/lib/python2.6/site-packages/resource_management/core/", line 140, in _call_wrapper
    result = _call(command, **kwargs_copy)
  File "/usr/lib/python2.6/site-packages/resource_management/core/", line 293, in _call
    raise ExecutionFailed(err_msg, code, out, err)
resource_management.core.exceptions.ExecutionFailed: Execution of 'storm kill enrichment' returned 1. Running: /usr/jdk64/jdk1.8.0_77/bin/java -client -Dstorm.options= -Dstorm.home=/usr/hdp/ -Dstorm.log.dir=/var/log/storm -Djava.library.path=/usr/local/lib:/opt/local/lib:/usr/lib:/usr/hdp/current/storm-client/lib -Dstorm.conf.file= -cp /usr/hdp/ org.apache.storm.command.kill_topology enrichment
Exception in thread "main" NotAliveException(msg:enrichment is not alive)
	at org.apache.storm.generated.Nimbus$killTopologyWithOpts_result$
	at org.apache.storm.generated.Nimbus$killTopologyWithOpts_result$
	at org.apache.storm.generated.Nimbus$
	at org.apache.storm.thrift.TServiceClient.receiveBase(
	at org.apache.storm.generated.Nimbus$Client.recv_killTopologyWithOpts(
	at org.apache.storm.generated.Nimbus$Client.killTopologyWithOpts(
	at org.apache.storm.command.kill_topology$_main.doInvoke(kill_topology.clj:27)
	at clojure.lang.RestFn.applyTo(
	at org.apache.storm.command.kill_topology.main(Unknown Source)

3.when i the xth time (Ambari all stop & all starrt)

resource_management.core.exceptions.ExecutionFailed: Execution of '/usr/hdp/current/kafka-broker/bin/                                 --zookeeper node1:2181                                 --create                                 --topic enrichments                                 --partitions 1                                 --replication-factor 1                                 --config retention.bytes=10737418240' returned 1. Error while executing topic command : Topic "enrichments" already exists.
[2017-08-31 13:19:52,449] ERROR kafka.common.TopicExistsException: Topic "enrichments" already exists.
	at kafka.admin.AdminUtils$.createOrUpdateTopicPartitionAssignmentPathInZK(AdminUtils.scala:420)
	at kafka.admin.AdminUtils$.createTopic(AdminUtils.scala:404)
	at kafka.admin.TopicCommand$.createTopic(TopicCommand.scala:110)
	at kafka.admin.TopicCommand$.main(TopicCommand.scala:61)
	at kafka.admin.TopicCommand.main(TopicCommand.scala)


Ambari on Chrome(node1:8080) Image


What should i do??

Please help me.

Thank you So much.


Expert Contributor

hi @choi Bongjae,

I don't know the guide that you gollow but if you follow this guide (pretty simple)

Normally you should not have any issue to install hdp + metron install (only few command and click 🙂 )


i can't see for mac install. Can i follow ububtu guide?

Rising Star

"Quick Dev" is not actively maintained currently. Please use the "Full Dev" environment in metron-deployment/vagrant/full-dev-environment.


Thank you for reply.

I am trying full dev install my mac.

Terminal stopped loading

"TASK [ambari_config : Deploy cluster with Ambari; http://node1:8080]**********"

It takes too long to load, and I do not know if it is normal. An hour and a half from the start of the installation

Please advice