Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

Atlas Dashboard UI / Atlas Metaserver URL not working

Contributor

Hello,

After a fresh Atlas Service Installation, the Atlas UI Server does not start:

Ambari: 2.4.2

HDP: 2.5.3

Cluster: kerberized

Output:

Connection failed to http://node04.mynet:21000/api/atlas/admin/status (Execution of 'curl --location-trusted -k --negotiate -u : -b /var/lib/ambari-agent/tmp/cookies/d0afeedb-c192-4fce-a7a2-179ab7f76ae8 -c /var/lib/ambari-agent/tmp/cookies/d0afeedb-c192-4fce-a7a2-179ab7f76ae8 -w '%{http_code}' http://node04.mynet:21000/api/atlas/admin/status --connect-timeout 5 --max-time 7 -o /dev/null 1>/tmp/tmp6wrMPb 2>/tmp/tmpjHYnZm' returned 7. curl: (7) couldn't connect to host
000)

All other services are working, node04 is pingable and reachable by all other nodes. SSH is working.

WHY cannot atlas see itself, while all other services on the same node are working?

Thanks,

Normen

9 REPLIES 9

Contributor

My atlas node config looks like this:

atlas.rest.address=http://node04.mynet:21000
atlas.server.address.id1=node04.mynet:21000
atlas.server.bind.address=node04.mynet
atlas.server.ha.enabled=false
atlas.server.http.port=21000
atlas.server.https.port=21443
atlas.server.ids=id1
atlas.solr.kerberos.enable=true

Contributor
Execution of 'source /etc/atlas/conf/atlas-env.sh ; /usr/hdp/current/atlas-server/bin/atlas_start.py' returned 255. Exception: [Errno 2] No such file or directory 
Traceback (most recent call last):
  File "/usr/hdp/current/atlas-server/bin/atlas_start.py", line 149, in <module>
    returncode = main()
  File "/usr/hdp/current/atlas-server/bin/atlas_start.py", line 72, in main
    mc.expandWebApp(atlas_home)
  File "/usr/hdp/2.5.3.0-37/atlas/bin/atlas_config.py", line 143, in expandWebApp
    jar(atlasWarPath)
  File "/usr/hdp/2.5.3.0-37/atlas/bin/atlas_config.py", line 196, in jar
    process = runProcess(commandline)
  File "/usr/hdp/2.5.3.0-37/atlas/bin/atlas_config.py", line 232, in runProcess
    p = subprocess.Popen(commandline, stdout=stdoutFile, stderr=stderrFile, shell=shell)
  File "/usr/lib64/python2.6/subprocess.py", line 642, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.6/subprocess.py", line 1238, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

Guru

Have you checked Ambari? Atlas requires Infra, Hbase, Kafka to be running as well as the Atlas service.

Contributor

Hello Vasilis,

Yes, Infra clients, HBase, Kafka is all running well. The only thing which is not healthy is the Atlas UI Server.

Expert Contributor

@Normen Zoch

Can you check if Atlas process is running on server with command ps -ef | grep "Atlas"

Also verify the atlas logs which can tell more about the failure in /var/logs/atlas/application.log

Contributor

One Update:

https://community.hortonworks.com/questions/39061/atlas-fails-to-start-on-ambari-22-and-hdp-242.html

Entpacking the atlas.war file is part of the solution so it seams. So look like, the Atlas Installer is broken.

I could start the Atlas Server but

Now i got an 503 Error

HTTP ERROR: 503

Problem accessing /. Reason:

    Service Unavailable

Powered by Jetty://

Expert Contributor

@Normen Zoch

Can you verify the atlas logs which can tell you more about the failure in /var/logs/atlas/application.log

Contributor

So, the following Process seem to solve this issue.

- Remove / Delete Atlas again

- Remove Ambari Infra again

- Install Ambari Infra

- Install Atlas

go to: /usr/hdp/current/atlas-server/server/webapp

- unpack atlas.war archive with: jar vxf atlas.war

- Set Permissions for atlas:

chown -R atlas ./*

chgrp -R hadoop ./*

Verify if /etc/atlas/conf/solr is also set to atlas:hadoop

Start Atlas Server in Ambari

Contributor

I forgot...this looks clearly like an devops error and / or broken installation.