Support Questions
Find answers, ask questions, and share your expertise

Atlas Dashboard UI not working

Atlas Dashboard UI not working

New Contributor

HI Team,

Atlas Dashboard UI not working, getting below error in Ambari.

Metadata Server Web UI

HTTP 503 response from https://localhost:21443/api/atlas/admin/status in 0.000s ( % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 103 310 103 310 0 0 15303 0 --:--:-- --:--:-- --:--:-- 302k)

WARN

Also Find the application log error.

) Error injecting constructor, org.apache.atlas.typesystem.exception.TypeExistsException: Cannot redefine type PHIat org.apache.atlas.services.DefaultMetadataService.<init>(DefaultMetadataService.java:117)at org.apache.atlas.services.DefaultMetadataService.class(DefaultMetadataService.java:93)while locating org.apache.atlas.services.DefaultMetadataServiceCaused by: org.apache.atlas.typesystem.exception.TypeExistsException: Cannot redefine type PHI

7 errors

at com.google.inject.internal.Errors.throwCreationExceptionIfErrorsExist(Errors.java:466)

at com.google.inject.internal.InternalInjectorCreator.injectDynamically(InternalInjectorCreator.java:184)

at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:110)

at com.google.inject.Guice.createInjector(Guice.java:96)

at com.google.inject.Guice.createInjector(Guice.java:84)


1 REPLY 1

Re: Atlas Dashboard UI not working

New Contributor

Hi, did you get a chance to look at this? https://community.hortonworks.com/questions/60125/atlas-ui-not-working-on-docker-hdp-25-sandbox-afte...

Looks like another user had a very similar error.