Support Questions
Find answers, ask questions, and share your expertise

Atlas Lineage Issue

New Contributor

Hi,

I have installed Atlas 2.0.0 using tarball on a Cloudera 6.1 Cluster, I am using Hbase and Solr as backend store, While importing both Hive and Kafka Lineage I see issue in the UI, For Hive only i can see Lineage for external tables, not for Managed table and also column level lineage is not visible, Just want to find where the issue is I tried with embedded solr and Kafka  still the same issue persists, For Kafka Lineage too I am facing same issue.

Following is the error I could see in the application.log, struggling with this issue for quite sometime any inputs is highly appreciated, I have one Kafka broker and my offsets.topic.replication.factor=1 and Cluster is an unsecured cluster and I could see message flowing in both the Kafka topics without any issue using console consumer and producer.

 

ERROR - [pool-2-thread-6 - bd16ff99-871b-4248-a41b-2a022a6fabee:] ~ graph rollback due to exception AtlasBaseException:Instance hive_table with unique attribute {qualifiedName=vdr_db.customer_vw8@primary} does not exist (GraphTransactionInterceptor:166)

 

The above error appears for hive_table and hive_process and for Kafka topic too.

Thanks,

Vishnu Ravi

1 REPLY 1

Explorer

Hi,

I am getting exactly same issue.

As a consequence, the data lineage is not shown in Atlas after import-hive.sh script is executed.

Did you resolve this topic? Could you please give me any hint?

 

Thanks a lot!

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.