Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Atlas UI not coming up after HDP 3.0.1.0-187, Ambari 2.7.0 upgrade

Solved Go to solution
Highlighted

Atlas UI not coming up after HDP 3.0.1.0-187, Ambari 2.7.0 upgrade

New Contributor

Hi,

I recently upgraded from HDP 2.6.3 to HDP 3.0.1.0-187 & Ambari from 2.6 to 2.7. After the upgrade Atlas UI is not coming up though the service is up and running fine, listening on https port 21443. There is no errors or warnings thrown in the application.log file. The below exception is from the .err log file. Anyone facing the same kind of issues in Altas after the upgrade? Any help would be appreciable.

Atlas version is 1.0.0

Exception in thread "main" org.apache.atlas.exception.AtlasBaseException: EmbeddedServer.Start: failed!
        at org.apache.atlas.web.service.EmbeddedServer.start(EmbeddedServer.java:101)
        at org.apache.atlas.Atlas.main(Atlas.java:133)
Caused by: MultiException[java.util.regex.PatternSyntaxException: Dangling meta character '*' near index 0
*NULL.*
^, java.util.regex.PatternSyntaxException: Dangling meta character '*' near index 0
*NULL.*
^]
        at org.eclipse.jetty.server.Server.doStart(Server.java:386)
        at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
        at org.apache.atlas.web.service.EmbeddedServer.start(EmbeddedServer.java:98)
        ... 1 more
        Suppressed: java.util.regex.PatternSyntaxException: Dangling meta character '*' near index 0
*NULL.*
^
                at java.util.regex.Pattern.error(Pattern.java:1957)
                at java.util.regex.Pattern.sequence(Pattern.java:2125)
                at java.util.regex.Pattern.expr(Pattern.java:1998)
                at java.util.regex.Pattern.compile(Pattern.java:1698)
                at java.util.regex.Pattern.<init>(Pattern.java:1351)
                at java.util.regex.Pattern.compile(Pattern.java:1028)
                at org.eclipse.jetty.util.ssl.SslContextFactory.removeExcludedCipherSuites(SslContextFactory.java:1204)
                at org.eclipse.jetty.util.ssl.SslContextFactory.selectCipherSuites(SslContextFactory.java:1163)
                at org.eclipse.jetty.util.ssl.SslContextFactory.load(SslContextFactory.java:320)
                at org.eclipse.jetty.util.ssl.SslContextFactory.doStart(SslContextFactory.java:217)
                at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
                at org.eclipse.jetty.util.component.ContainerLifeCycle.start(ContainerLifeCycle.java:131)
                at org.eclipse.jetty.util.component.ContainerLifeCycle.doStart(ContainerLifeCycle.java:105)
                at org.eclipse.jetty.server.SslConnectionFactory.doStart(SslConnectionFactory.java:72)
                at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
                at org.eclipse.jetty.util.component.ContainerLifeCycle.start(ContainerLifeCycle.java:131)
                at org.eclipse.jetty.util.component.ContainerLifeCycle.doStart(ContainerLifeCycle.java:105)
                at org.eclipse.jetty.server.AbstractConnector.doStart(AbstractConnector.java:268)
                at org.eclipse.jetty.server.AbstractNetworkConnector.doStart(AbstractNetworkConnector.java:81)
                at org.eclipse.jetty.server.ServerConnector.doStart(ServerConnector.java:235)
                at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
                at org.eclipse.jetty.server.Server.doStart(Server.java:401)
                ... 3 more
Caused by: java.util.regex.PatternSyntaxException: Dangling meta character '*' near index 0
*NULL.*
^
        at java.util.regex.Pattern.error(Pattern.java:1957)
        at java.util.regex.Pattern.sequence(Pattern.java:2125)
        at java.util.regex.Pattern.expr(Pattern.java:1998)
        at java.util.regex.Pattern.compile(Pattern.java:1698)
        at java.util.regex.Pattern.<init>(Pattern.java:1351)
        at java.util.regex.Pattern.compile(Pattern.java:1028)
        at org.eclipse.jetty.util.ssl.SslContextFactory.removeExcludedCipherSuites(SslContextFactory.java:1204)
        at org.eclipse.jetty.util.ssl.SslContextFactory.selectCipherSuites(SslContextFactory.java:1163)
        at org.eclipse.jetty.util.ssl.SslContextFactory.load(SslContextFactory.java:320)
        at org.eclipse.jetty.util.ssl.SslContextFactory.doStart(SslContextFactory.java:217)
        at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
        at org.eclipse.jetty.util.component.ContainerLifeCycle.start(ContainerLifeCycle.java:131)
        at org.eclipse.jetty.util.component.ContainerLifeCycle.doStart(ContainerLifeCycle.java:113)
        at org.eclipse.jetty.server.SslConnectionFactory.doStart(SslConnectionFactory.java:72)
        at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
        at org.eclipse.jetty.util.component.ContainerLifeCycle.start(ContainerLifeCycle.java:131)
        at org.eclipse.jetty.util.component.ContainerLifeCycle.doStart(ContainerLifeCycle.java:113)
        at org.eclipse.jetty.server.AbstractConnector.doStart(AbstractConnector.java:268)
        at org.eclipse.jetty.server.AbstractNetworkConnector.doStart(AbstractNetworkConnector.java:81)
        at org.eclipse.jetty.server.ServerConnector.doStart(ServerConnector.java:235)
        at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
        at org.eclipse.jetty.server.Server.doStart(Server.java:401)
        ... 3 more
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Atlas UI not coming up after HDP 3.0.1.0-187, Ambari 2.7.0 upgrade

Hi @Cibi Chakaravarthi,

Go to Ambari UI>Atlas >Configs (Filter for property atlas.ssl.exclude.cipher.suites)

Set as below and restart the service

atlas.ssl.exclude.cipher.suites=.*NULL.*, .*RC4.*, .*MD5.*, .*DES.*, .*DSS.*

I guess a '.' is missing before *NULL* is your problem.

Please login and accept the answer if this helps you

2 REPLIES 2

Re: Atlas UI not coming up after HDP 3.0.1.0-187, Ambari 2.7.0 upgrade

Hi @Cibi Chakaravarthi,

Go to Ambari UI>Atlas >Configs (Filter for property atlas.ssl.exclude.cipher.suites)

Set as below and restart the service

atlas.ssl.exclude.cipher.suites=.*NULL.*, .*RC4.*, .*MD5.*, .*DES.*, .*DSS.*

I guess a '.' is missing before *NULL* is your problem.

Please login and accept the answer if this helps you

Re: Atlas UI not coming up after HDP 3.0.1.0-187, Ambari 2.7.0 upgrade

New Contributor

@Akhil S Naik Thanks for the quick reply. The missing '.' was the issue and the web ui is up now.