Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Atlas installation does not work

Solved Go to solution

Atlas installation does not work

New Contributor

Hello,

Under Ambari 2.5.1 Atlas has been installed just after Hbase and Kafka (required modules)

Atlas Metadata Server does not start and I don't see any logs or messages (/var/log/atlas is emty)

Does anyone has an idea on how to resolve this kind of issue ?

Thanks in advance

Regards

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Atlas installation does not work

Super Mentor

@Lou Richard

Good to know that the issue is resolved. It will be great if you can mark this HCC thread as Answered by clicking on the "Accept" Button. That way other HCC users can quickly find the solution when they encounter the same issue.

As it was a long thread hence i am writing a brief summary for the HCC users who might encounter this issue and can quickly find the answer.

Issue: Atlas Installation Was failing with the following error:

File "/usr/hdp/2.6.1.0-129/atlas/bin/atlas_config.py", line 232, in runProcess  p = subprocess.Popen(commandline, stdout=stdoutFile, stderr=stderrFile, shell=shell)  
File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__  errread, errwrite)  
File "/usr/lib64/python2.7/subprocess.py", line 1327, in _execute_child   
raise child_exceptionOSError: [Errno 2] No such file or director

.
Solution: Making sure that the JAVA_HOME is set correctly on the host and it is pointing to a valid JDK (not JRE) and setting the JAVA_HOME properly inside the global environment variable.

# cd /usr/hdp/2.6.1.0-129/atlas/server/webapp/
# mv atlas  ../
# /usr/lib/jvm/jre-1.8.0-openjdk/bin/jar -xf atlas.war

.
Cause:
"jar" utility comes with JDK (inside $JAVA_HOME/bin) which is being used by the "atlas_config.py" script to extract the atlas.war.

19 REPLIES 19

Re: Atlas installation does not work

Expert Contributor

@Lou Richard Can you share the Ambari log after starting Atlas Metadata server? It must have some information about the failure.

Re: Atlas installation does not work

Expert Contributor

If you could let us know these details, it will help in getting towards a solution:

  • What are the deployment environment details?
  • How was the build done? Information about Maven parameters will help.
  • Is it SSL or non-SSL environment? Is Kerboros used?

When atlas_start.py is executed, do you see new process getting created? If yes, what are the classpath details?

Re: Atlas installation does not work

New Contributor

Hello guys,

Thanks for your reply.

I am beginner so there arre some terms I don't understand well, sorry...

  • Deployment env : Linux cent OS 7.3 64 bits with ambari 2.5.1 with 3 nodes and each 8GB of RAM
  • Installation by HDP package with Yum. I don't know Maven
  • Non SSL with Kerberos

I finally found this error logs in the ops popup window

Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/common-services/ATLAS/0.1.0.2.3/package/scripts/metadata_server.py", line 181, in <module>
    MetadataServer().execute()
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 329, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/common-services/ATLAS/0.1.0.2.3/package/scripts/metadata_server.py", line 117, in start
    not_if=no_op_test
  File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 155, in __init__
    self.env.run()
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 160, in run
    self.run_action(resource, action)
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 124, in run_action
    provider_action()
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 262, in action_run
    tries=self.resource.tries, try_sleep=self.resource.try_sleep)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 72, in inner
    result = function(command, **kwargs)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 102, in checked_call
    tries=tries, try_sleep=try_sleep, timeout_kill_strategy=timeout_kill_strategy)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 150, in _call_wrapper
    result = _call(command, **kwargs_copy)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 303, in _call
    raise ExecutionFailed(err_msg, code, out, err)
resource_management.core.exceptions.ExecutionFailed: Execution of 'source /usr/hdp/current/atlas-server/conf/atlas-env.sh ; /usr/hdp/current/atlas-server/bin/atlas_start.py' returned 255. Exception: [Errno 2] No such file or directory 
Traceback (most recent call last):
  File "/usr/hdp/current/atlas-server/bin/atlas_start.py", line 149, in <module>
    returncode = main()
  File "/usr/hdp/current/atlas-server/bin/atlas_start.py", line 73, in main
    mc.expandWebApp(atlas_home)
  File "/usr/hdp/2.6.1.0-129/atlas/bin/atlas_config.py", line 143, in expandWebApp
    jar(atlasWarPath)
  File "/usr/hdp/2.6.1.0-129/atlas/bin/atlas_config.py", line 196, in jar
    process = runProcess(commandline)
  File "/usr/hdp/2.6.1.0-129/atlas/bin/atlas_config.py", line 232, in runProcess
    p = subprocess.Popen(commandline, stdout=stdoutFile, stderr=stderrFile, shell=shell)
  File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1327, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

Thanks

LR

Re: Atlas installation does not work

Super Mentor

@Lou Richard

We see the cause of failure as following:

File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__    errread, errwrite)  
File "/usr/lib64/python2.7/subprocess.py", line 1327, in _execute_child    
raise child_exceptionOSError: [Errno 2] No such file or directory

So can you please check the following directory to see if the "atlas.war" is extracted there or not? And the directory permission is set to "atlas:hadoop"

# ls /usr/hdp/2.6.1.0-129/atlas/server/webapp/
atlas  atlas.war

### Permission atlas:hadoop
# ls -ld  /usr/hdp/2.6.1.0-129/atlas/server/webapp
drwxr-xr-x 1 atlas hadoop 4096 xxx 19 18:51 /usr/hdp/2.6.1.0-129/atlas/server/webapp

.

If it is not extracted there properly then please try to extract the war and then see if it works.

.

Re: Atlas installation does not work

New Contributor

This is the check :

[root@hadoop001 ~]# ls /usr/hdp/2.6.1.0-129/atlas/server/webapp/
atlas  atlas.war
[root@hadoop001 ~]# ls -ld  /usr/hdp/2.6.1.0-129/atlas/server/webapp
drwxr-xr-x 3 atlas hadoop 4096 Oct  9 15:41 /usr/hdp/2.6.1.0-129/atlas/server/webapp

Re: Atlas installation does not work

Super Mentor

@Lou Richard

Do you have the "JAVA_HOME" property set properly?

After reviewing the script "atlas_config.py" the only thing that i am suspecting at this point ... maybe the JAVA_HOME is not properly set. As the execution "commandline" variable in the script looks for it.

.

I will also suggest if you can try manually extracting the file to see if it works:

# cd /usr/hdp/2.6.1.0-129/atlas/server/webapp/
# mv atlas  ../
# $JAVA_HOME/bin/jar -xf atlas.war

.

Then try restarting the Atlas.

Highlighted

Re: Atlas installation does not work

New Contributor

I suppose JAVA_HOME is set properly :

[root@hadoop001 webapp]# echo $JAVA_HOME
/usr/lib/jvm/jre-1.8.0-openjdk

I did what you suggested and :

[root@hadoop001 webapp]# $JAVA_HOME/bin/jar -xf atlas.war
-bash: /usr/lib/jvm/jre-1.8.0-openjdk/bin/jar: No such file or directory

There is no bin/jar on the server (I searched with the locate command)

Re: Atlas installation does not work

Super Mentor

@Lou Richard

You are using JRE (Not JDK): "/usr/lib/jvm/jre-1.8.0-openjdk"

I am suspecting that it might be because of missing "jar" utility which is used to extract the war.

https://github.com/apache/incubator-atlas/blob/master/distro/src/bin/atlas_config.py#L193-L196

.

Can you please install a JDK (not JRE) on your host and then set the JAVA_HOME properly.

Re: Atlas installation does not work

New Contributor

Sorry to ask that but how to install JDK ?

I don't understand because I have the following packages :

[root@hadoop001]# rpm -qa|grep jre
[root@hadoop001]# rpm -qa|grep jdk
java-1.8.0-openjdk-headless-1.8.0.141-1.b16.el7_3.x86_64
java-1.8.0-openjdk-1.8.0.141-1.b16.el7_3.x86_64
copy-jdk-configs-1.2-1.el7.noarch

Don't have an account?
Coming from Hortonworks? Activate your account here