Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Atlas installation does not work

Solved Go to solution

Re: Atlas installation does not work

Super Mentor

@Lou Richard

JDK requirement: https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.1/bk_support-matrices/content/ch_matrices-hdp...

One option is to set the java_home for the cluster using setup command as following: , Using this option when you plan to use a JDK other than the default Oracle JDK 1.8. If you are using an alternate JDK, you must manually install the same JDK on all hosts and specify the Java Home path during Ambari Server setup.

# ambari-server setup --java-home=/usr/jdk64/jdk1.8.0_121


https://docs.hortonworks.com/HDPDocuments/Ambari-2.5.1.0/bk_ambari-installation/content/setup_option...

Highlighted

Re: Atlas installation does not work

Super Mentor

@Lou Richard

Looks like you already have "java-1.8.0-openjdk-1.8.0.141-1.b16.el7_3.x86_64" present in your atlas host.

So all you need to do is that locate that JDK and then set the JAVA_HOME some thing like :

export JAVA_HOME=/PATH/TO/java-1.8.0-openjdk-1.8.0.141

.

Example: In the file "/etc/profile" we can set the JAVA_HOME for all the users globally. You will need to find the exact location of your JDK 1.8.0.141 installation on your file system and then set it accordingly.

export JAVA_HOME=/usr/jdk64/java-1.8.0-openjdk-1.8.0.141
export PATH=$JAVA_HOME/bin:$PATH

.

Re: Atlas installation does not work

New Contributor

Well, JAVA_HOME is already set in /etc/profile

The actual value is /usr/lib/jvm/jre-1.8.0-openjdk-1.8.0.141-1.b16.el7_3.x86_64

The value given above

/usr/lib/jvm/jre-1.8.0-openjdk 

is a link to /usr/lib/jvm/jre-1.8.0-openjdk-1.8.0.141-1.b16.el7_3.x86_64

The 3 nodes are exactly the same they have the same version of all components

Re: Atlas installation does not work

Super Mentor

@Lou Richard

Please try this:

# cd /usr/hdp/2.6.1.0-129/atlas/server/webapp/
# mv atlas  ../
# /usr/lib/jvm/jre-1.8.0-openjdk/bin/jar -xf atlas.war

.

And then try restarting the atlas.

Re: Atlas installation does not work

New Contributor

I already tried it :

 /usr/lib/jvm/jre-1.8.0-openjdk/bin/jar: No such file or directory

So we tried using unzip but it is the same

Re: Atlas installation does not work

Super Mentor

@Lou Richard

You are using JRE (/usr/lib/jvm/jre-1.8.0-openjdk/bin/) which does not have "jar" utility inside the it's "bin" directory.

You need JDK (not JRE).

https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.0/bk_command-line-installation/content/meet-m...

Re: Atlas installation does not work

New Contributor

Ok thanks, I'm going to try "Manually Installing Oracle JDK 1.7 or 1.8"..

Re: Atlas installation does not work

New Contributor

Ok so JDK installed and jar on the machine.

But still the same error .... :-(

Re: Atlas installation does not work

New Contributor

Sorry we forgot to modify the environment variable and now it works !

Thanks a lot for your help :-)

Re: Atlas installation does not work

Super Mentor

@Lou Richard

Good to know that the issue is resolved. It will be great if you can mark this HCC thread as Answered by clicking on the "Accept" Button. That way other HCC users can quickly find the solution when they encounter the same issue.

As it was a long thread hence i am writing a brief summary for the HCC users who might encounter this issue and can quickly find the answer.

Issue: Atlas Installation Was failing with the following error:

File "/usr/hdp/2.6.1.0-129/atlas/bin/atlas_config.py", line 232, in runProcess  p = subprocess.Popen(commandline, stdout=stdoutFile, stderr=stderrFile, shell=shell)  
File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__  errread, errwrite)  
File "/usr/lib64/python2.7/subprocess.py", line 1327, in _execute_child   
raise child_exceptionOSError: [Errno 2] No such file or director

.
Solution: Making sure that the JAVA_HOME is set correctly on the host and it is pointing to a valid JDK (not JRE) and setting the JAVA_HOME properly inside the global environment variable.

# cd /usr/hdp/2.6.1.0-129/atlas/server/webapp/
# mv atlas  ../
# /usr/lib/jvm/jre-1.8.0-openjdk/bin/jar -xf atlas.war

.
Cause:
"jar" utility comes with JDK (inside $JAVA_HOME/bin) which is being used by the "atlas_config.py" script to extract the atlas.war.

Don't have an account?
Coming from Hortonworks? Activate your account here