Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Building storm-streaming 1.0-SNAPSHOT error

avatar
Contributor

Hi, i'm running REALTIME EVENT PROCESSING IN HADOOP WITH NIFI, KAFKA AND STORM tutorial, and got an error. I try many way but couldn't save it. I've used another version of maven, try add two dependencies but it's didn't changed. I Here is my error:

[WARNING] The POM for org.apache.kafka:kafka_2.10:jar:0.10.0.2.5.1.0-9 is missing, no dependency information available [WARNING] The POM for org.apache.storm:storm-core:jar:1.0.1.2.5.1.0-9 is missing, no dependency information available [WARNING] The POM for org.apache.storm:storm-kafka:jar:1.0.1.2.5.1.0-9 is missing, no dependency information available [WARNING] The POM for org.apache.storm:storm-hdfs:jar:1.0.1.2.5.1.0-9 is missing, no dependency information available [WARNING] The POM for org.apache.storm:storm-hbase:jar:1.0.1.2.5.1.0-9 is missing, no dependency information available [WARNING] The POM for org.apache.hadoop:hadoop-client:jar:2.7.3.2.5.1.0-9 is missing, no dependency information available

..............................

[ERROR] Failed to execute goal on project storm-streaming: Could not resolve dependencies for project com.hortonworks:storm-streaming:jar:1.0-SNAPSHOT: The following artifacts could not be resolved: poc.hortonworks.domain:transport-domain:jar:1.0.0-SNAPSHOT, org.apache.kafka:kafka_2.10:jar:0.10.0.2.5.1.0-9, org.apache.storm:storm-core:jar:1.0.1.2.5.1.0-9, org.apache.storm:storm-kafka:jar:1.0.1.2.5.1.0-9, org.apache.storm:storm-hdfs:jar:1.0.1.2.5.1.0-9, org.apache.storm:storm-hbase:jar:1.0.1.2.5.1.0-9, org.apache.hadoop:hadoop-client:jar:2.7.3.2.5.1.0-9, org.apache.hbase:hbase-client:jar:1.1.2.2.5.1.0-9, org.apache.hive:hive-exec:jar:2.1.0.2.5.1.0-9, org.apache.hive.hcatalog:hive-hcatalog-streaming:jar:2.1.0.2.5.1.0-9, org.apache.hive.hcatalog:hive-hcatalog-core:jar:2.1.0.2.5.1.0-9, org.apache.hive:hive-cli:jar:2.1.0.2.5.1.0-9: Could not find artifact poc.hortonworks.domain:transport-domain:jar:1.0.0-SNAPSHOT in clojars.org (http://clojars.org/repo) -> [Help 1]

Please help me. I'm using HDP 2.4. Many thanks!

1 ACCEPTED SOLUTION

avatar
Super Guru
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
11 REPLIES 11

avatar
Super Guru
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Contributor

this is already exist in my file. Here's my pom.xml in Storm streaming:

pom.xml

avatar
Super Guru

@Davd Leh

can you try this, I have updated the dependencies

pom.xml

avatar
Contributor

Hi @Rajkumar Singh, i used your pom.xml and now i get another error The POM for org.apache.hadoop:hadoop-client:jar:2.7.3.2.5.1.0-59 is missing, no dependency information available. Numbers of missing dependency is reduced. But this is remain.

avatar
Contributor

Finally i'm done, i used your file, and i edited the line <hadoop.version>2.7.3.2.5.1.0-59</hadoop.version> to <hadoop.version>2.7.3.2.5.1.0-58</hadoop.version>. it works!. Thank you!

avatar
Super Guru

@Davd Leh good to hear that it helped, could you accept a best answer here so that other user can get benefit of it.thanks

avatar
Master Guru

Try building with the -Phortonworks profile, or adding

http://repo.hortonworks.com/content/repositories/releases/

to the list of repositories in the POM

avatar
Contributor

Thank you, this solution is not applicable.

avatar
New Contributor

The "Best Answer" still does not work for me. I cannot resolve

<dependency>
<groupId>poc.hortonworks.domain</groupId> <artifactId>transport-domain</artifactId> 
<version>${truck.topology.domain.version}</version>
</dependency>
...
[WARNING] The POM for poc.hortonworks.domain:transport-domain:jar:1.0.0-SNAPSHOT is missing, no dependency information available
...

Any other suggestions?