Support Questions

Find answers, ask questions, and share your expertise

CDH upgrade to 5.11 fails with "Fails to Install Oozie ShareLib"

Expert Contributor



I am upgrading cluster to 5.11 and the upgrade wizard fails at this point where its instlaling oozie Share Lib


Error: Copy task failed with exception Stack trace for the error was (for debug purposes): -------------------------------------- org.apache.hadoop.ipc.RemoteException( File /user/oozie/share/lib/lib_20170606145204/sqoop/asm-3.2.jar could only be replicated to 0 nodes instead of minReplication (=1). There are 3 datanode(s) running and no node(s) are excluded in this operation. at org.apache.hadoop.hdfs.server.blockmanagement.BlockManager.chooseTarget4NewBlock( at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.getAdditionalBlock( at org.apache.hadoop.hdfs.server.namenode.NameNodeRpcServer.addBlock( at org.apache.hadoop.hdfs.server.namenode.AuthorizationProviderProxyClientProtocol.addBlock( at org.apache.hadoop.hdfs.protocolPB.ClientNamenodeProtocolServerSideTranslatorPB.addBlock( at org.apache.hadoop.hdfs.protocol.proto.ClientNamenodeProtocolProtos$ClientNamenodeProtocol$2.callBlockingMethod( at org.apache.hadoop.ipc.ProtobufRpcEngine$Server$ at org.apache.hadoop.ipc.RPC$ at org.apache.hadoop.ipc.Server$Handler$ at org.apache.hadoop.ipc.Server$Handler$ at Method) at at at org.apache.hadoop.ipc.Server$ at at at org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.invoke( at com.sun.proxy.$Proxy16.addBlock(Unknown Source) at org.apache.hadoop.hdfs.protocolPB.ClientNamenodeProtocolTranslatorPB.addBlock( at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke( at java.lang.reflect.Method.invoke( at at at com.sun.proxy.$Proxy17.addBlock(Unknown Source) at org.apache.hadoop.hdfs.DFSOutputStream$DataStreamer.locateFollowingBlock( at org.apache.hadoop.hdfs.DFSOutputStream$DataStreamer.nextBlockOutputStream( at org.apache.hadoop.hdfs.DFSOutputStream$




Any advise on how to fix this ? 



What is the state of HDFS?  It is simply stating that it is trying to write the jar file to HDFS in the Oozie shared lib location but it is unable to write out any replicats to the 3 available DNs.

Expert Contributor

HDFS is in good standing.

I can read a file and put a file in HDFS.  Ran hdfs fsck and it looks good with no corrupt blocks. 

Tried to go to oozie and clickthe option Install Oozie shareLib and it still does not work. fails at that place. 


When i look at at /user/oozie/share/lib  , i can see it creates a directory but does not copy files. it fails after copying a few.  Tried deleting the whole share directory and copying again. still the same.