Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

CM Installation Failed with PostgreSQL 8.4 dependency

Highlighted

CM Installation Failed with PostgreSQL 8.4 dependency

Contributor

Hello,

 

I am trying to deploy a POC cluster using Path A of CM Installation. It is failing with below message from logs:

 

cat 5.install-cloudera-manager-server-db-2.log 
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package cloudera-manager-server-db-2.x86_64 0:5.15.1-1.cm5151.p0.3.el7 will be installed
--> Processing Dependency: postgresql-server >= 8.4 for package: cloudera-manager-server-db-2-5.15.1-1.cm5151.p0.3.el7.x86_64
--> Finished Dependency Resolution
Error: Package: cloudera-manager-server-db-2-5.15.1-1.cm5151.p0.3.el7.x86_64 (cloudera-manager)
           Requires: postgresql-server >= 8.4
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I also attempted to create a local repository of both CM and PostgreSQL and executed .bin with --skip_repo_package=1. However,

  1. I was unable to find PostgreSQL 8.4 package for CentOS / RedHat 7 any where, so downloaded and created repo of PostgreSQL 9.6.
  2. CM was further looking for 9.6 dependencies, which was again a list of 5-6 packages.

Not sure, how to proceed, please help.

 

Thanks

snm1523