Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Can i upgrade my Java version to Java SE 8u171/ 8u172 on Cloudera Enterprise 5.11.1

SOLVED Go to solution

Can i upgrade my Java version to Java SE 8u171/ 8u172 on Cloudera Enterprise 5.11.1

New Contributor

Hi All,

 

I want to upgrade my Java version to Java SE 8u171/ 8u172 on Cloudera Enterprise 5.11.1 in the Production environment. Does Cloudera support this. 

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: Can i upgrade my Java version to Java SE 8u171/ 8u172 on Cloudera Enterprise 5.11.1

Champion

based on the Cloudera KM below is the latest / recommended version that was tested 

1.8u144

Re: Can i upgrade my Java version to Java SE 8u171/ 8u172 on Cloudera Enterprise 5.11.1

Expert Contributor

According to Cloudera "https://www.cloudera.com/documentation/enterprise/release-notes/topics/rn_consolidated_pcm.html#conc..."

JDK 8
All JDK 8 updates, from the minimum required version, are supported in Cloudera 
Manager/CDH 5.3 and higher unless specifically excluded. Updates above the
minimum that are not listed are supported but not tested.

So, as about your question, 8u171 is supported but not tested. Not tested means that you may be the first which will face some issues. In such case, were issue is due to a bug in JDK version, Cloudera will add this version as "excluded".

 

If you want to be safe, then use the latest tested, mentioned by @csguna

3 REPLIES 3

Re: Can i upgrade my Java version to Java SE 8u171/ 8u172 on Cloudera Enterprise 5.11.1

Champion

based on the Cloudera KM below is the latest / recommended version that was tested 

1.8u144

Re: Can i upgrade my Java version to Java SE 8u171/ 8u172 on Cloudera Enterprise 5.11.1

Expert Contributor

According to Cloudera "https://www.cloudera.com/documentation/enterprise/release-notes/topics/rn_consolidated_pcm.html#conc..."

JDK 8
All JDK 8 updates, from the minimum required version, are supported in Cloudera 
Manager/CDH 5.3 and higher unless specifically excluded. Updates above the
minimum that are not listed are supported but not tested.

So, as about your question, 8u171 is supported but not tested. Not tested means that you may be the first which will face some issues. In such case, were issue is due to a bug in JDK version, Cloudera will add this version as "excluded".

 

If you want to be safe, then use the latest tested, mentioned by @csguna

Highlighted

Re: Can i upgrade my Java version to Java SE 8u171/ 8u172 on Cloudera Enterprise 5.11.1

New Contributor