Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Can not access cloudera WEB UI. After Installing it Successfully.

avatar
Explorer

I Followed these steps :

 

First i took a server(Cent OS 6) from Google Cloud in Asia South reagion. and Executed these commands :

 

  1. sudo -i
  2. chkconfig iptables off
  3. service iptables stop
  4. setenforce 0
  5. vi /etc/selinux/config (SELINUX=disabled)
  6. init 6
  7. wget http://archive.cloudera.com/cm5/installer/latest/cloudera-manager-installer.bin
  8. chmod u+x cloudera-manager-installer.bin
  9. sudo ./cloudera-manager-installer.bin

Done! Cloudera manager installed Successfully.

But when I am trying to access http://my_public_ip:7180/ then getting timed out error.

Also i waited for almost an hour after installing cloudera(for startup settings). but again same response.

1 ACCEPTED SOLUTION

avatar
Expert Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
17 REPLIES 17

avatar
Master Guru

@Gaurav,

 

The first thing to check is whether the server is up and listening.

- service cloudera-scm-server status

- netstat -nap |grep 7180

 

Next, check the Cloudera Manager server log to find out if it had trouble starting.

- review /var/log/cloudera-scm-server/cloudera-scm-server.log

 

If you do find that Cloudera Manager is listening on 7180, make sure it is listening on all interfaces.

If you are getting a timed out message or a hang, that makes me suspicious that the server is coming up, but your route to that host is not working properly.  Could there be a proxy configured in your browser that cannot connect to your CM server?

You might try tcpdump or browser developer tools to find out what the client/server communication looks like.

 

I'd start with making sure the server is listening on 7180 and review the log for any exceptions or errors that look important.

 

avatar
Explorer

Hi @bgooley,

 

Thankyou for response.

here what i got

 1. service cloudera-scm-server status

     Running

 

 2. netstat -nap |grep 7180

 

tcp        0      0 0.0.0.0:7180                0.0.0.0:*                   LISTEN      1623/java

 

 

and it seems that all right in log file.

avatar
Expert Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Explorer

Thankyou @bgooley for the help.

 

I Just figured it out by tcpdump. now it's working.

avatar
Explorer

I am also facing the same issue, can you let me know how did you solve it

avatar
Master Guru

Hi @dewdrop,

 

Please see my initial comments in this thread.  We'll need to know more about what you try to do and what the result is.

 

Thanks,

 

Ben

avatar
Explorer

Hi,

 

I've installed cloudera Manager on Amazon VM Ec2 server.

 

disabled SELinux, disabled filewall setting

 

sudo service cloudera-scm-server status - up and running

 

netstat -nap |grep 7180
(No info could be read for "-p": geteuid()=1000 but you should be root.)
tcp 0 0 0.0.0.0:7180 0.0.0.0:* LISTEN

 

i tried these two on the running server 

 

ec2-user@ip-172-31-44-224 ~]$ curl -i http://localhost:7180
HTTP/1.1 200 OK
Expires: Thu, 01-Jan-1970 00:00:00 GMT
Set-Cookie: CLOUDERA_MANAGER_SESSIONID=sgoy1bydivup1kmcoqv110bfu;Path=/;HttpOnly
Content-Type: text/html; charset=utf-8
Last-Modified: Wed, 07 Feb 2018 17:44:18 GMT
Content-Length: 63
Accept-Ranges: bytes
Cache-Control: max-age=3600,public
Server: Jetty(6.1.26.cloudera.4)

<head><meta http-equiv="refresh" content="0;url=/cmf/"></head>

 

curl -i -u 'admin:admin' http://localhost:7180/api/v1/tools/echo
HTTP/1.1 200 OK
Expires: Thu, 01-Jan-1970 00:00:00 GMT
Set-Cookie: CLOUDERA_MANAGER_SESSIONID=ubst7780j868jkzeysc0a31;Path=/;HttpOnly
Content-Type: application/json
Date: Wed, 28 Mar 2018 18:30:20 GMT
Transfer-Encoding: chunked
Server: Jetty(6.1.26.cloudera.4)

{
"message" : "Hello, World!"

}

both returned an output,

 

However when trying to access the below url from chrome or fixefox i am getting the below error

http://ip-172-31-44-224.us-west-2.compute.internal:7180

 

Error : 

We can’t connect to the server at ip-172-31-44-224.
If that address is correct, here are three other things you can try:

 

Any suggestions would be very helpful.

 

Thanks,

 

avatar
Explorer
Hi @dewdrop,

Which Cloud Service are You using.
Have you allowed Port 7180 to access publicly?

avatar
Explorer
EC2 and port 7180 is open for public access

[ec2-user@ip-172-31-44-224 ~]$ netstat -na | grep 7180
tcp 0 0 0.0.0.0:7180 0.0.0.0:* LISTEN