Support Questions
Find answers, ask questions, and share your expertise

Can't Install R on HDP 2.6 cluster


I setup a HDP 2.6 cluster using Hortonworks Data Cloud (HDCloud) for AWS. I tried to install R on the HDP cluster, but failed. Below are error messages when I tried to install R on the master node. Thanks for helps.

sudo yum install R R-devel libcurl-devel openssl-devel


---> Package libcurl-devel.x86_64 0:7.51.0-4.73.amzn1 will be installed [Errno 14] HTTP Error 404 - Not Found Trying other mirror. To address this issue please refer to the below knowledge base article If above article doesn't help to resolve this issue please open a ticket with Red Hat Support. One of the configured repositories failed (HDP-UTILS-, and yum doesn't have enough cached data to continue. At this point the only safe thing yum can do is fail. There are a few ways to work "fix" this: 1. Contact the upstream for the repository and get them to fix the problem. 2. Reconfigure the baseurl/etc. for the repository, to point to a working upstream. This is most often useful if you are using a newer distribution release than is supported by the repository (and the packages for the previous distribution release still work). 3. Disable the repository, so yum won't use it by default. Yum will then just ignore the repository until you permanently enable it again or use --enablerepo for temporary usage: yum-config-manager --disable HDP-UTILS- 4. Configure the failing repository to be skipped, if it is unavailable. Note that yum will try to contact the repo. when it runs most commands, so will have to try and fail each time (and thus. yum will be be much slower). If it is a very temporary problem though, this is often a nice compromise: yum-config-manager --save --setopt=HDP-UTILS- failure: repodata/4a066ab87ef4593992315a707eee5184dc6fce29d982f0f6e7b61399d33779ed-filelists.sqlite.bz2 from HDP-UTILS- [Errno 256] No more mirrors to try. [Errno 14] HTTP Error 404 - Not Found



Try to change hdp-utils.repo's baseurl to ""

hello do you know where to find this hdp-utils.repo ?

; ;