Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Can't find cloudera 5.7 parcel

Solved Go to solution

Can't find cloudera 5.7 parcel

Explorer

Hi, guys!

 

I'm trying to install cloudera using CM api. Today I started seeing this problem: can't find CDH 5.7 even though the repo is specified:Screen Shot 2017-11-11 at 1.58.52 AM.png

 

In the parcels page I see a bunch of parcels, but not the CDH 5.7 one.

 

Screen Shot 2017-11-11 at 1.59.03 AM.png

 

 

Also, on another Cluster I started seeing these messages:

 

ReadWriteDatabaseTaskCallable

Error while executing CmfEntityManager task
java.lang.NullPointerException
	at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:191)
	at com.google.common.collect.Collections2.filter(Collections2.java:92)
	at com.cloudera.parcel.components.ParcelDownloaderImpl$RepositoryInfo.getParcelsWithValidNames(ParcelDownloaderImpl.java:673)
	at com.cloudera.parcel.components.ParcelDownloaderImpl$RepositoryInfo.getSortedParcels(ParcelDownloaderImpl.java:691)
	at com.cloudera.parcel.components.ParcelDownloaderImpl.syncRemoteRepos(ParcelDownloaderImpl.java:368)
	at com.cloudera.parcel.components.ParcelDownloaderImpl$1.run(ParcelDownloaderImpl.java:438)
	at com.cloudera.parcel.components.ParcelDownloaderImpl$1.run(ParcelDownloaderImpl.java:433)
	at com.cloudera.cmf.persist.ReadWriteDatabaseTaskCallable.call(ReadWriteDatabaseTaskCallable.java:36)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)

The first one happened at November 10, 2017 5:59 PM.

 

This message is happening on the new clusters as well.

 

Is everything ok with the repo?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Can't find cloudera 5.7 parcel

Explorer
Still don't know the exact cause of it. Fixed the issue by removing Cloudera Manager's default parcel repositories and left only that which I need
14 REPLIES 14

Re: Can't find cloudera 5.7 parcel

Explorer
Still don't know the exact cause of it. Fixed the issue by removing Cloudera Manager's default parcel repositories and left only that which I need

Re: Can't find cloudera 5.7 parcel

Explorer
https://archive.cloudera.com/sqoop-connectors/parcels/latest has some toxic content. Removing it from the list of remote repositories solved the problem for me.

Re: Can't find cloudera 5.7 parcel

Expert Contributor

Hi,

 

Are you saying that when you removed the SQOOP-CONNECTORS  ( https://archive.cloudera.com/sqoop-connectors/parcels/latest ) URL from the parcels list you were able to see your CDH upgrade choice?

 

I want to report this behavior if that is true.

 

Thank you - Tina

Highlighted

Re: Can't find cloudera 5.7 parcel

Explorer

Tina, for me - removing all repos but CDH 5.7 one (including sqoop connector) solved the problem.

Re: Can't find cloudera 5.7 parcel

Expert Contributor

Thank you for your answer.   I am going to use this information and test this.

 

 

Re: Can't find cloudera 5.7 parcel

Explorer
Any news on this? I still have problems for some deploys with https://archive.cloudera.com/cdh5/parcels/5.7/

Re: Can't find cloudera 5.7 parcel

Expert Contributor

I cannot reproduce this.   What version of CM are you using? 

Re: Can't find cloudera 5.7 parcel

Explorer
It's CM 5.13

Re: Can't find cloudera 5.7 parcel

Expert Contributor

I cannot reproduce this issue, even on CM5.13.0.

 

I can confirm that you will only see the latest released version of CDH if you only have this repo, the default, in your parcel list:

 

https://archive.cloudera.com/cdh5/parcels/{latest_supported}/

 

The latest supported release would be the one that matches your CM version.   CM5.10.x would see CDH5.10.x, CM5.13.0 would see CDH5.13.x and so on.

 

To see a version of CDH that is lower than the one you have running you will have to point directly to that repo.

CM5.8.x and higher, to see CDH5.7.x would need to add http://archive.cloudera.com/cdh5/parcels/5.7/ to the repo list.

 

As far as the sqoop repo being corrupt or causing issues, I have contacted those responsible to look into it.