Support Questions
Find answers, ask questions, and share your expertise

Can't upgrade from 2.6.4 to 2.6.5 because of SOLR

New Contributor

Trying to upgrade HDP 2.6.4 to HDP 2.6.5. Gets 99% done and then I get an error about Solr.


We tried setting the version in the Ambari database, didn't seem to make any difference.

If I try to start Solr now I get the following error.

Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/common-services/SOLR/", line 101, in <module>
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/", line 375, in execute
  File "/var/lib/ambari-agent/cache/common-services/SOLR/", line 46, in start
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/", line 120, in locking_configure
    original_configure(obj, *args, **kw)
  File "/var/lib/ambari-agent/cache/common-services/SOLR/", line 22, in configure
  File "/var/lib/ambari-agent/cache/common-services/SOLR/", line 28, in setup_solr
  File "/usr/lib/ambari-agent/lib/resource_management/core/", line 150, in __init__
    super(InlineTemplate, self).__init__(name, extra_imports, **kwargs) 
  File "/usr/lib/ambari-agent/lib/resource_management/core/", line 137, in __init__
    self.template = self.template_env.get_template(     
  File "/usr/lib/ambari-agent/lib/ambari_jinja2/", line 716, in get_template
    return self._load_template(name, self.make_globals(globals))
  File "/usr/lib/ambari-agent/lib/ambari_jinja2/", line 686, in _load_template
    template = self.cache.get(name)
  File "/usr/lib/ambari-agent/lib/ambari_jinja2/", line 405, in get
    return self[key]
  File "/usr/lib/ambari-agent/lib/ambari_jinja2/", line 448, in __getitem__
    rv = self._mapping[key]
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/", line 73, in __getattr__
    raise Fail("Configuration parameter '" + + "' was not found in configurations dictionary!")
resource_management.core.exceptions.Fail: Configuration parameter 'content' was not found in configurations dictionary!

Anyone have any idea what's going on and how we might get past this?


@joel patterson,

What error are you getting at 99% stage?

Please attach a screenshot. also see if there is any errors in ambari-server.log file

New Contributor

This is all it shows me when looking at details. We tried setting the version in the Ambari database, but made no difference.


Hi @Joel Patterson ,

It seems like some of requried configs of SOLR is missing .

So my question is are you Actually Using SOLR as a ambari managed service and SOLR i shown in ambari Services UI ?

If not you can actually follow this Blog to delete the Service from database :

(My assumption is your SOLR is not visible in UI and cannot delete service as you mentioned you have version unknown in database )

Before Deleting, Stop upgrade and revert back upgrade .

If you have SOLR running and everything is fine , try to give the missing parameter to ambari using :

# /var/lib/ambari-server/resources/scripts/ --user=admin --password=admin --port=8080 --action=set --host=localhost --cluster=<Enter_your_cluster_name> --config-type=<CONFIG_TYPE>