Support Questions
Find answers, ask questions, and share your expertise

Cannot Connect Tableau to HiveServer2

Contributor

I have a default Ambari 2.3 install, meaning I have not changed much from the default.

From the Services->Hive page I can tell HiveServer2 is running and on which node it is running. Also if I go into Services->Hive->Config->Advanced I can see my security authorization is none and authentication is none.

When I attempt to attach Tableau to HiveServer2 with the proper node on port 10000 and no authentication it does not connect.

I can tell the Tableau workstation is attempting to connect to the HiveServer2 on port 10000 via 'netstat -peant'.

When I look in the HiveServer2 logs, as soon as I attempt to connect from Tableau I get this error:

----

2016-04-07 16:02:52,205 ERROR [HiveServer2-Handler-Pool: Thread-142]: server.TThreadPoolServer (TThreadPoolServer.java:run(296)) - Error occurred during processing of message.

java.lang.RuntimeException: org.apache.thrift.transport.TTransportException: Invalid status -128

at org.apache.thrift.transport.TSaslServerTransport$Factory.getTransport(TSaslServerTransport.java:219) at org.apache.thrift.server.TThreadPoolServer$WorkerProcess.run(TThreadPoolServer.java:268) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) at java.lang.Thread.run(Thread.java:745)

Caused by: org.apache.thrift.transport.TTransportException: Invalid status -128

at org.apache.thrift.transport.TSaslTransport.sendAndThrowMessage(TSaslTransport.java:232) at org.apache.thrift.transport.TSaslTransport.receiveSaslMessage(TSaslTransport.java:184) at org.apache.thrift.transport.TSaslServerTransport.handleSaslStartMessage(TSaslServerTransport.java:125) at org.apache.thrift.transport.TSaslTransport.open(TSaslTransport.java:271)at org.apache.thrift.transport.TSaslServerTransport.open(TSaslServerTransport.java:41)

at org.apache.thrift.transport.TSaslServerTransport$Factory.getTransport(TSaslServerTransport.java:216)

... 4 more

1 ACCEPTED SOLUTION

Hive expects a SASL Wrapper from the client. ( empty in your case ). And doesnt seem to get any or with a wrong status. Is it possible that the odbc driver is old? Did you use the ODBC driver from here?

http://hortonworks.com/hdp/addons/

View solution in original post

6 REPLIES 6

Hive expects a SASL Wrapper from the client. ( empty in your case ). And doesnt seem to get any or with a wrong status. Is it possible that the odbc driver is old? Did you use the ODBC driver from here?

http://hortonworks.com/hdp/addons/

Contributor

"Hive expects a SASL Wrapper from the client."

^^^^ That was the ticket.

Once I read into this a bit and configured accordingly, everything worked!

Thank you again!

Expert Contributor

Adding onto Benjamin's answer - as this may be helpful to others having similar issues:

When using HiveServer2, always use the Authentication as "user name" (you may use root to connect to the hwx sandbox)

Contributor

@marksf can you help me out on this.

I am facing similar issue... Is it problem with odbc driver?

Contributor

@marksf or anyone, can you please provide that article or ticket information please -

Hive expects a SASL Wrapper from the client

Contributor

@marksf...Could you please tell me how did you resolve this?

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.