Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cannot build HBase from source code.

Highlighted

Cannot build HBase from source code.

New Contributor

Hi Guys

 

I'm trying to build the HBase from source code (https://github.com/cloudera/hbase.git where i checked out the build) with this command "mvn clean package -Dhadoop.profile=2.0  -Psecurity -DskipTests", but i always get the following errors, is the build OK? Or did i miss something?  Thank you guys.

 

[INFO] Scanning for projects...
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building HBase 0.94.6-cdh4.4.0
[INFO] ------------------------------------------------------------------------
Downloading: https://repository.cloudera.com/artifactory/cloudera-repos/org/apache/hadoop/hadoop-minicluster/2.0....
Downloading: https://repository.apache.org/content/repositories/releases/org/apache/hadoop/hadoop-minicluster/2.0...
Downloading: https://repository.cloudera.com/content/groups/cdh-releases-rcs/org/apache/hadoop/hadoop-minicluster...
Downloading: https://repository.cloudera.com/content/repositories/third-party/org/apache/hadoop/hadoop-minicluste...
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 4.156s
[INFO] Finished at: Thu Oct 31 11:03:55 CST 2013
[INFO] Final Memory: 8M/265M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project hbase: Could not resolve dependencies for project org.apache.hbase:hbase:jar:0.94.6-cdh4.4.0: Failed to collect dependencies at org.apache.hadoop:hadoop-minicluster:jar:2.0.0-cdh4.4.0: Failed to read artifact descriptor for org.apache.hadoop:hadoop-minicluster:jar:2.0.0-cdh4.4.0: Could not transfer artifact org.apache.hadoop:hadoop-minicluster:pom:2.0.0-cdh4.4.0 from/to cdh.repo (https://repository.cloudera.com/artifactory/cloudera-repos): peer not authenticated -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException

2 REPLIES 2

Re: Cannot build HBase from source code.

Contributor
Can you try -Dhadoop.profile=23?

Highlighted

Re: Cannot build HBase from source code.

New Contributor

Checked the pom.xml, tried this one, and it works:

mvn clean package -Dhadoop.profile=2.0 -Dhadoop.version=2.2.0 -Dcdh.hadoop.version=2.2.0 -P security -DskipTests

 

But can anyone tell me what're the correct values for all above values if i want to build the same jar as CDH4.4? As I know Hadoop 2.2.0 is just released. Thank you.

Don't have an account?
Coming from Hortonworks? Activate your account here