Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cannot find a valid baseurl for repo: HDP-3.1-repo-5 while adding spark as service on ambari cluster

Highlighted

Cannot find a valid baseurl for repo: HDP-3.1-repo-5 while adding spark as service on ambari cluster

New Contributor

The 'hadoop-yarn-timelineserver' component did not advertise a version. This may indicate a problem with the component packaging.

Traceback (most recent call last):

File /ambari-agent/cache/stacks/HDP/3.0/services/YARN/package/scripts/application_timeline_server.py, line 97, in 

ApplicationTimelineServer().execute()

File /ambari-agent/lib/resource_management/libraries/script/script.py, line 352, in execute

method(env)

File /ambari-agent/cache/stacks/HDP/3.0/services/YARN/package/scripts/application_timeline_server.py, line 42, in install

self.install_packages(env)

File /ambari-agent/lib/resource_management/libraries/script/script.py, line 839, in install_packages

name = self.format_package_name(package['name'])

File /ambari-agent/lib/resource_management/libraries/script/script.py, line 562, in format_package_name

return self.get_package_from_available(name)

File /ambari-agent/lib/resource_management/libraries/script/script.py, line 529, in get_package_from_available

raise Fail(No package found for {0}(expected name: {1}).format(name, name_with_version))

resource_management.core.exceptions.Fail: No package found for hadoop_${stack_version}-yarn(expected name: hadoop_3_1-yarn)


I have verified that base url is present in ambari.repo and ambari-hdp.repo files under /etc/yum.repos.d/ , and I also used it to install ambari cluster itself.

2 REPLIES 2

Re: Cannot find a valid baseurl for repo: HDP-3.1-repo-5 while adding spark as service on ambari cluster

Super Mentor

@Kk Kk

I am suspecting that you might be hitting the same scenario which is described in the following HCC thread: (although you may or may not be using the Local repo)

https://community.hortonworks.com/questions/247051/switching-to-local-repo-artifactory-is-causing-th...


Although if you are using Latest Ambari 2.7 then you should not face that issue which is mentioned in the above hcc thread.


Re: Cannot find a valid baseurl for repo: HDP-3.1-repo-5 while adding spark as service on ambari cluster

Community Manager

The above question was originally posted in the Community Help track. On Thu Jul 4 19:25 UTC 2019, a member of the HCC moderation staff moved it to the Hadoop Core track. The Community Help Track is intended for questions about using the HCC site itself, not technical questions about installation using Ambari.