Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cannot install Infra Solr Instance: Failed to execute command '/usr/bin/yum -y install ambari-infra-solr', exited with code '1', message: 'Error: Nothing to do

Cannot install Infra Solr Instance: Failed to execute command '/usr/bin/yum -y install ambari-infra-solr', exited with code '1', message: 'Error: Nothing to do

New Contributor

I'm having this error when trying to install the Infra Solr on Ambari 2.7.3 and HDP 3.1

stderr: /var/lib/ambari-agent/data/errors-22.txt

Traceback (most recent call last): File "/var/lib/ambari-agent/cache/common-services/AMBARI_INFRA_SOLR/0.1.0/package/scripts/infra_solr.py", line 171, in <module> InfraSolr().execute() File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 352, in execute method(env) File "/var/lib/ambari-agent/cache/common-services/AMBARI_INFRA_SOLR/0.1.0/package/scripts/infra_solr.py", line 43, in install self.install_packages(env) File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 849, in install_packages retry_count=agent_stack_retry_count) File "/usr/lib/ambari-agent/lib/resource_management/core/base.py", line 166, in __init__ self.env.run() File "/usr/lib/ambari-agent/lib/resource_management/core/environment.py", line 160, in run self.run_action(resource, action) File "/usr/lib/ambari-agent/lib/resource_management/core/environment.py", line 124, in run_action provider_action() File "/usr/lib/ambari-agent/lib/resource_management/core/providers/packaging.py", line 30, in action_install self._pkg_manager.install_package(package_name, self.__create_context()) File "/usr/lib/ambari-agent/lib/ambari_commons/repo_manager/yum_manager.py", line 219, in install_package shell.repository_manager_executor(cmd, self.properties, context) File "/usr/lib/ambari-agent/lib/ambari_commons/shell.py", line 753, in repository_manager_executor raise RuntimeError(message) RuntimeError: Failed to execute command '/usr/bin/yum -y install ambari-infra-solr', exited with code '1', message: 'Error: Nothing to do

stdout: /var/lib/ambari-agent/data/output-22.txt

2019-02-27 07:07:16,473 - Stack Feature Version Info: Cluster Stack=3.1, Command Stack=None, Command Version=None -> 3.1 2019-02-27 07:07:16,480 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf 2019-02-27 07:07:16,481 - Group['hdfs'] {} 2019-02-27 07:07:16,489 - Group['hadoop'] {} 2019-02-27 07:07:16,489 - Group['users'] {} 2019-02-27 07:07:16,489 - User['yarn-ats'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hadoop'], 'uid': None} 2019-02-27 07:07:16,490 - User['infra-solr'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hadoop'], 'uid': None} 2019-02-27 07:07:16,491 - User['zookeeper'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hadoop'], 'uid': None} 2019-02-27 07:07:16,491 - User['ams'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hadoop'], 'uid': None} 2019-02-27 07:07:16,492 - User['ambari-qa'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hadoop', 'users'], 'uid': None} 2019-02-27 07:07:16,493 - User['hdfs'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hdfs', 'hadoop'], 'uid': None} 2019-02-27 07:07:16,493 - User['yarn'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hadoop'], 'uid': None} 2019-02-27 07:07:16,494 - User['mapred'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hadoop'], 'uid': None} 2019-02-27 07:07:16,495 - File['/var/lib/ambari-agent/tmp/changeUid.sh'] {'content': StaticFile('changeToSecureUid.sh'), 'mode': 0555} 2019-02-27 07:07:16,515 - Execute['/var/lib/ambari-agent/tmp/changeUid.sh ambari-qa /tmp/hadoop-ambari-qa,/tmp/hsperfdata_ambari-qa,/home/ambari-qa,/tmp/ambari-qa,/tmp/sqoop-ambari-qa 0'] {'not_if': '(test $(id -u ambari-qa) -gt 1000) || (false)'} 2019-02-27 07:07:16,533 - Skipping Execute['/var/lib/ambari-agent/tmp/changeUid.sh ambari-qa /tmp/hadoop-ambari-qa,/tmp/hsperfdata_ambari-qa,/home/ambari-qa,/tmp/ambari-qa,/tmp/sqoop-ambari-qa 0'] due to not_if 2019-02-27 07:07:16,533 - Group['hdfs'] {} 2019-02-27 07:07:16,533 - User['hdfs'] {'fetch_nonlocal_groups': True, 'groups': ['hdfs', 'hadoop', u'hdfs']} 2019-02-27 07:07:16,534 - FS Type: HDFS 2019-02-27 07:07:16,534 - Directory['/etc/hadoop'] {'mode': 0755} 2019-02-27 07:07:16,550 - File['/usr/hdp/current/hadoop-client/conf/hadoop-env.sh'] {'content': InlineTemplate(...), 'owner': 'hdfs', 'group': 'hadoop'} 2019-02-27 07:07:16,552 - Writing File['/usr/hdp/current/hadoop-client/conf/hadoop-env.sh'] because contents don't match 2019-02-27 07:07:16,569 - Directory['/var/lib/ambari-agent/tmp/hadoop_java_io_tmpdir'] {'owner': 'hdfs', 'group': 'hadoop', 'mode': 01777} 2019-02-27 07:07:16,584 - Repository['HDF-3.3-repo-1'] {'base_url': 'http://public-repo-1.hortonworks.com/HDF/centos7/3.x/updates/3.3.0.0', 'action': ['prepare'], 'components': [u'HDF', 'main'], 'repo_template': '[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0', 'repo_file_name': 'ambari-hdp-1', 'mirror_list': None} 2019-02-27 07:07:16,608 - Repository['HDP-3.1-repo-1'] {'base_url': 'http://public-repo-1.hortonworks.com/HDP/centos7/3.x/updates/3.1.0.0', 'action': ['prepare'], 'components': [u'HDP', 'main'], 'repo_template': '[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0', 'repo_file_name': 'ambari-hdp-1', 'mirror_list': None} 2019-02-27 07:07:16,610 - Repository['HDP-3.1-GPL-repo-1'] {'base_url': 'http://public-repo-1.hortonworks.com/HDP-GPL/centos7/3.x/updates/3.1.0.0', 'action': ['prepare'], 'components': [u'HDP-GPL', 'main'], 'repo_template': '[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0', 'repo_file_name': 'ambari-hdp-1', 'mirror_list': None} 2019-02-27 07:07:16,613 - Repository['HDP-UTILS-1.1.0.22-repo-1'] {'base_url': 'http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.22/repos/centos7', 'action': ['prepare'], 'components': [u'HDP-UTILS', 'main'], 'repo_template': '[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0', 'repo_file_name': 'ambari-hdp-1', 'mirror_list': None} 2019-02-27 07:07:16,615 - Repository[None] {'action': ['create']} 2019-02-27 07:07:16,622 - File['/tmp/tmpbtsF37'] {'content': ...} 2019-02-27 07:07:16,623 - Writing File['/tmp/tmpbtsF37'] because contents don't match 2019-02-27 07:07:16,645 - File['/tmp/tmpWtKk7f'] {'content': StaticFile('/etc/yum.repos.d/ambari-hdp-1.repo')} 2019-02-27 07:07:16,646 - Writing File['/tmp/tmpWtKk7f'] because contents don't match 2019-02-27 07:07:16,646 - Package['unzip'] {'retry_on_repo_unavailability': False, 'retry_count': 5} 2019-02-27 07:07:18,032 - Skipping installation of existing package unzip 2019-02-27 07:07:18,033 - Package['curl'] {'retry_on_repo_unavailability': False, 'retry_count': 5} 2019-02-27 07:07:18,041 - Skipping installation of existing package curl 2019-02-27 07:07:18,041 - Package['hdp-select'] {'retry_on_repo_unavailability': False, 'retry_count': 5} 2019-02-27 07:07:18,048 - Skipping installation of existing package hdp-select 2019-02-27 07:07:18,053 - The repository with version 3.1.0.0-78 for this command has been marked as resolved. It will be used to report the version of the component which was installed 2019-02-27 07:07:18,057 - Skipping stack-select on AMBARI_INFRA_SOLR because it does not exist in the stack-select package structure. 2019-02-27 07:07:18,251 - Package['ambari-infra-solr-client'] {'retry_on_repo_unavailability': False, 'retry_count': 5} 2019-02-27 07:07:18,327 - Skipping installation of existing package ambari-infra-solr-client 2019-02-27 07:07:18,328 - Package['ambari-infra-solr'] {'retry_on_repo_unavailability': False, 'retry_count': 5} 2019-02-27 07:07:18,337 - Installing package ambari-infra-solr ('/usr/bin/yum -y install ambari-infra-solr') 2019-02-27 07:07:23,271 - The repository with version 3.1.0.0-78 for this command has been marked as resolved. It will be used to report the version of the component which was installed 2019-02-27 07:07:23,275 - Skipping stack-select on AMBARI_INFRA_SOLR because it does not exist in the stack-select package structure. Command failed after 1 tries
Don't have an account?
Coming from Hortonworks? Activate your account here