Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Cannot log into Ambari Dashboard for HDP2.5 Azure Sandbox

Rising Star

Created a new HDP2.5 Sandbox on Azure today. I can log into Ambari Dashboard for my old HDP2.4 Sandox using http://host:8080 or http://host:8888 but not with my new HDP2.5 one. It just times out. I tried ssh'g into my Sandbox to check if Ambari was running and/or start it manually but no luck. Any advice anyone?

[root@sandbox ~]# ambari-agent-password-reset
-bash: ambari-agent-password-reset: command not found

[root@sandbox ~]# ps -ef | grep Ambari
root 4772 1 2 18:53 ? 00:03:13 /usr/lib/jvm/java/bin/java -server -XX:NewRatio=3 -XX:+UseConcMarkSweepGC -XX:-UseGCOverheadLimit -XX:CMSInitiatingOccupancyFraction=60 -XX:+CMSClassUnloadingEnabled -Xms512m -Xmx2048m -XX:MaxPermSize=128m -cp /etc/ambari-server/conf:/usr/lib/ambari-server/*:/usr/share/java/postgresql-jdbc.jar org.apache.ambari.server.controller.AmbariServer

root 7473 1 0 18:56 ? 00:00:00 /usr/bin/python /usr/lib/python2.6/site-packages/ambari_agent/ start
root 18654 18552 0 21:12 pts/1 00:00:00 grep --color=auto Ambari
[root@sandbox ~]# ambari-server start
-bash: ambari-server: command not found
[root@sandbox ~]# yum list | grep ambari-agent
Repodata is over 2 weeks old. Install yum-cron? Or run: yum makecache fast
[root@sandbox ~]# rpm -qa | grep ambari-server
[root@sandbox ~]#


Rising Star


@Suzanne Dimant

In one of your posts you linked to: and brought up an issue with the default password.

The password is the same one that you set up when originally deploying the sandbox on Azure. Additionally, the user ("azure" in the tutorial) is whatever user you specified during setup.

Hope that helps!



@Suzanne Dimant

To add: There are added security measures to HDP 2.5 on Azure, so you can SSH in just fine, but by default all other ports on Azure are closed. You can either open up the ports, or SSH tunnel (recommended) by following the tutorial above.

Rising Star

Thanks @Edgar Orendain ... I read those port-forwarding instructions too literally. Modified my ~./ssh/config using the username I created when I set up my Sandbox and was able to ssh in using the port-forwarding alias, however I still get ‘command not found’ when running ‘ambari-admin-password-reset’ as root.

After setting up port-forwarding, literally typing ‘http://localhost:8888' got me to the splash screen. When I clicked on ‘Launch Dashboard’ I got a log on screen and tried ever username/password combination I could think of. No luck. Also when I try ‘http://localhost:8080’ I get an error that my browser can’t connect.

Rising Star


most likely you have logged on as root from visualbox/vmware console to ssh to 22 port.

you need to ssh to 2222 or or web client

then you can reset the ambari asmin password by using



I am also seeing the same issues on my 2.5 version of Sandbox on Azure.I am a new user to both Azure, HDP Sandbox and i was not expecting this, also i wonder why we don't have AWS based HDP sandbox?

  1. ambari-agent-password-reset
  2. -bash: ambari-agent-password-reset: command not found