Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cannot perform SHOW queries through Hortonworks ODBC driver with a kerberos-enabled cluster

Solved Go to solution
Highlighted

Cannot perform SHOW queries through Hortonworks ODBC driver with a kerberos-enabled cluster

Explorer

Hi,

I'm facing the following problem :

When I run SHOW queries through HortonWorks ODBC Driver with my kerberos-enable cluster, it returns an empty result (there is no error, just an empty result). However, I can perform SELECT queries, I can also run CREATE DATABASE or CREATE TABLE queries.

Note : I can perform SHOW queries using beeline client.

Note 2 : I tried to activate TRACE logging for the driver, and I get one error :

"Sep 28 18:48:03.508 ERROR 2741458688 Connection::SQLSetConnectAttr: [Hortonworks][ODBC] (11470) Transactions are not supported."

Any idea ?

Thanks in advance,

Sylvain.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Cannot perform SHOW queries through Hortonworks ODBC driver with a kerberos-enabled cluster

Explorer

Ok I have the solution.

We were using ODBC via OTL and so we needed to set a particular flag "ImplicitSelect" to "true" directly on the connection level. When this flag is not set, "SHOW" queries return empty results.

Thanks,

Sylvain.

View solution in original post

3 REPLIES 3
Highlighted

Re: Cannot perform SHOW queries through Hortonworks ODBC driver with a kerberos-enabled cluster

Explorer

Are you using tableau to run your hive query?

Re: Cannot perform SHOW queries through Hortonworks ODBC driver with a kerberos-enabled cluster

Explorer

No, I'm using my own software based on Hortonworks ODBC driver (SHOW queries used to work without kerberos).

Highlighted

Re: Cannot perform SHOW queries through Hortonworks ODBC driver with a kerberos-enabled cluster

Explorer

Ok I have the solution.

We were using ODBC via OTL and so we needed to set a particular flag "ImplicitSelect" to "true" directly on the connection level. When this flag is not set, "SHOW" queries return empty results.

Thanks,

Sylvain.

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here