Support Questions
Find answers, ask questions, and share your expertise
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cannot run program "/etc/hadoop/conf.cloudera.yarn/" (in directory "/home/bigdata)


Cannot run program "/etc/hadoop/conf.cloudera.yarn/" (in directory "/home/bigdata)


I tried to run this code 


 import org.apache.spark.mllib.linalg.{Vector, Vectors}
import org.apache.spark.mllib.linalg.Vector
import org.apache.spark.mllib.linalg.distributed.RowMatrix
val v0 = Vectors.dense(1.0, 0.0, 3.0)
val v1 = Vectors.sparse(3, Array(1), Array(2.5))
val v2 = Vectors.sparse(3, Seq((0, 1.5), (1, 1.8)))
val rows = sc.parallelize(Seq(v0,v1,v2))
val mat: RowMatrix = new RowMatrix(rows)
val m = mat.numRows()

 After performing RDD reduce operation it throws error:


:38 WARN net.ScriptBasedMapping: Exception running /etc/hadoop/conf.cloudera.yarn/ xxx.xx.x.xx Cannot run program "/etc/hadoop/conf.cloudera.yarn/" (in directory "/home/bigdata/DATA"): error=13, Permission denied
at java.lang.ProcessBuilder.start(
at org.apache.hadoop.util.Shell.runCommand(
at org.apache.hadoop.util.Shell$ShellCommandExecutor.execute(
at org.apache.hadoop.yarn.util.RackResolver.coreResolve(
at org.apache.hadoop.yarn.util.RackResolver.resolve( .......................


I tried to resolve issue using this post  stackoverflow-post,cloudera community sport others . Still facing same issue.



Don't have an account?
Coming from Hortonworks? Activate your account here