Support Questions

Find answers, ask questions, and share your expertise

Cannot run program "hive": error=2, by using Oozie workflow with sqoop and hive import

hi all,

I am getting this error in Oozie by using sqoop and Hive import.

[main] ERROR org.apache.sqoop.tool.ImportTool  - Encountered IOException running import job: Cannot run program "hive": error=2, No such file or directory
Caused by: error=2, No such file or directory

Below is my Oozie workflow:
            <arg>SELECT STARTTIME FROM TEST WHERE STARTTIME BETWEEN TO_DATE('2017-06-08 14:00:00', 'YYYY-MM-DD HH24:MI:SS') AND TO_DATE('2017-06-08 14:10:59','YYYY-MM-DD HH24:MI:SS') AND  $CONDITIONS)</arg>
Could you please help me with the error? What files that I am missing?




@JT Ng Check if you have oozie sharelib updated.

Also, try adding --hive-home in sqoop <arg>


hi Shashank,

I added the args from your recommended. My job is killed but I dont see any ERROR in the log. Any idea ?



Rising Star

Are there any error messages in your log files?

Also, in the meantime, you might verify that you have a JDBC driver in /user/oozie/share/lib/lib_<timestamp>/sqoop.


I am also facing the same error message when using sqoop with oozie only. If i run the sqoop command individually it is working fine. i have tried with adding hive-home as well but still i am facing the same error. Is there any other way which we can solve the problem.


was this problem solved, what is the fix?