Support Questions
Find answers, ask questions, and share your expertise

Cannot send / receive any email while oozie-email action is executed

Hi All,

I was trying to configure and send a sample email using the sample workflow. But while executing the workflow i have encountered below issues. Can someone help me

Issue:

ErrorType [ERROR], ErrorCode [EM007], Message [EM007: Encountered an error while sending the email message over SMTP.]
org.apache.oozie.action.ActionExecutorException: EM007: Encountered an error while sending the email message over SMTP.
	at org.apache.oozie.action.email.EmailActionExecutor.email(EmailActionExecutor.java:269)
	at org.apache.oozie.action.email.EmailActionExecutor.validateAndMail(EmailActionExecutor.java:161)
	at org.apache.oozie.action.email.EmailActionExecutor.start(EmailActionExecutor.java:108)
	at org.apache.oozie.command.wf.ActionStartXCommand.execute(ActionStartXCommand.java:250)
	at org.apache.oozie.command.wf.ActionStartXCommand.execute(ActionStartXCommand.java:64)
	at org.apache.oozie.command.XCommand.call(XCommand.java:286)
	at org.apache.oozie.command.XCommand.call(XCommand.java:356)
	at org.apache.oozie.command.wf.SignalXCommand.execute(SignalXCommand.java:434)
	at org.apache.oozie.command.wf.SignalXCommand.execute(SignalXCommand.java:76)
	at org.apache.oozie.command.XCommand.call(XCommand.java:286)
	at org.apache.oozie.command.XCommand.call(XCommand.java:356)
	at org.apache.oozie.command.wf.ActionEndXCommand.execute(ActionEndXCommand.java:280)
	at org.apache.oozie.command.wf.ActionEndXCommand.execute(ActionEndXCommand.java:61)
	at org.apache.oozie.command.XCommand.call(XCommand.java:286)
	at org.apache.oozie.service.CallableQueueService$CallableWrapper.run(CallableQueueService.java:175)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
Caused by: com.sun.mail.smtp.SMTPSendFailedException: 530 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM

	at com.sun.mail.smtp.SMTPTransport.issueSendCommand(SMTPTransport.java:1388)
	at com.sun.mail.smtp.SMTPTransport.mailFrom(SMTPTransport.java:959)
	at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTransport.java:583)
	at javax.mail.Transport.send0(Transport.java:169)
	at javax.mail.Transport.send(Transport.java:98)
	at org.apache.oozie.action.email.EmailActionExecutor.email(EmailActionExecutor.java:265)

Custom oozie-site.xml

oozie.email.smtp.username=
oozie.email.smtp.password=
oozie.email.from.address=oozie@localhost
oozie.email.smtp.auth=false
oozie.email.smtp.host=smtp.XXX.com
oozie.email.smtp.port=25
oozie.service.SchemaService.wf.ext.schemas=email-action-0.1.xsd

Also Please help me any prerequisites for setting up an email notification for oozie as hadoop is installed on Ubuntu servers.

4 REPLIES 4

It Worked !!! Thanks @kvarakantham

New Contributor

@Vijay Kumar J,

can you explain its config smtp oozie ?

I have the same problem with you thks,

@anang andrianto

I have used the default smtp config. I haven't changed any. it worked for me.

New Contributor

can you give me screen shoot "smtp config'' ... ? thks @Vijay Kumar J