Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cannot start Impala only on CDH 5.2 with AMD Opteron ? Impala worked fine on CDH 5.1.3.

Highlighted

Cannot start Impala only on CDH 5.2 with AMD Opteron ? Impala worked fine on CDH 5.1.3.

New Contributor

Upgraded our test cluster from CDH 5.1.3 to CDH 5.2.0.1. No issues during upgrade and cluster starts fine except for Impala. No impala instances will start (statestore, catalog server, daemons). No role logs seem to be created,  stderr log reports below. Impala was working fine for us on CDH 4, CDH 5, CDH 5.1.3. Re-install of impala service results in same error.

 

The test cluster is based on 'older' SUN X4110 h/w with AMD Operton processors running RHEL 6.4.  Do not think these processsors support SSE3. Does Impala no longer work in CDH 5.2 without SSE3 where it was working under 5.1.3 using the same configuration ?

 

Starting Impala Service (e.g. remove and re-install)

 

First Run FinishedNov 6, 2014 4:53:33 PM GMTNov 6, 2014 4:53:58 PM GMT
Failed to perform First Run of services.
Command (7235) has failed

 

CATALOGSERVER/impala-conf/catalogserver_flags
WARNING: Logging before InitGoogleLogging() is written to STDERR
E1106 16:53:50.174782 29061 init.cc:117] CPU does not support the Supplemental SSE3 instruction set, which is required. This could lead to instability.
1 REPLY 1
Highlighted

Re: Cannot start Impala only on CDH 5.2 with AMD Opteron ? Impala worked fine on CDH 5.1.3.

New Contributor

Clarification: the processors are AMD Operaton 2220s (Santa Rosa). Think these processors support SSE3 but NOT Supplemental SSE3 (SSSE3/SSE3S) think err logs are referring to.

Don't have an account?
Coming from Hortonworks? Activate your account here