Support Questions

Find answers, ask questions, and share your expertise

CataloogD OutOfMemoryError, disabled loading catalog in background

New Contributor

There’s error from catalog server restarting on its own by giving OutOfMemoryError error. 

 

Based on the recommendation, changed the property "load_catalog_in_background" and set to false. Now catalog seems to be fine. But will there be any impact on query performance?

1 REPLY 1

Guru
Setting load_catalog_in_background only delays the OOM error. After you have queried all tables, it will crash eventually.

You should increase the memory limit for catalogd via CM > Impala > Configuration > "Java Heap Size of Catalog Server in Bytes", based on what you have now, increase it until it won't crash.

Cheers
Eric