Support Questions
Find answers, ask questions, and share your expertise
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Centos 7 having issues with P12 file (invalid password message )


Centos 7 having issues with P12 file (invalid password message )

New Contributor

I followed the article , and tried setting up a secure apache nifi registry. I am having issues with the P12 file. I Persistently get a message stating the password from the password file is not right. I tried this with gnome seahorse and from the command line . From the command line it encounters a parse failure .

My environment Centos 7 ( 3.10.0-862.14.4.el7.x86_64 ) NIFI Registry 0.3.0 NIFI tooolbit 1.8.0

Gnome Desktop version 3.22.1 using VTE version 0.46.2 +GNUTLS seahorse version 3.20.0

keychain 2.8.2 from Inheriting ssh-agent

command line trial gnome-keyring import CN=sys_admin_OU=NIFI.p12 gnome-keyring: couldn't parse: CN=sys_admin_OU=NIFI.p12 gnome-keyring: couldn't find any place to import files couldn't parse: CN=sys_admin_OU=NIFI.p12 Tried creating a keyring named NIFI , but this did not get anywhere.

Hoping someone elsewhere could have faced/resolved this or might have a tip .




Re: Centos 7 having issues with P12 file (invalid password message )

New Contributor

The default password generated by the toolkit did not work . I regenerated the certificates using the password option, and the certificates were taken in successfully both by windows and CenOS7.

Please treat my query as resolved, as it has cleared my immediate problem.


I have resolved the issue , by providing a password when generating the certificates using the toolkit. With the default password generated by toolkit utility , the P12 file could not be taken in by windows and CentOS7.

Don't have an account?
Coming from Hortonworks? Activate your account here