Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cloudbreak 1.4+ Cluster Deployment Fails (No default VPC for this user)

Cloudbreak 1.4+ Cluster Deployment Fails (No default VPC for this user)

New Contributor

Hello, I'm trying to evaluate HDP 2.5 using Cloudbreak 1.4+ but am unable to deploy any clusters. It appears as though the deployment is ignoring my specified VPC and trying to only use the default. I have tested version CBD 1.6 as well but the result is the same.

Has anyone else seen this issue, or have a suggestion on how to work around this? There is no way for me to define an existing SG either.

I also want to mention that cluster deployments worked for me on Cloudbreak 1.3.

9/29/2016 11:21:30 AM test - update in progress: Infrastructure creation failed. Reason: No default VPC for this user
9/29/2016 11:21:30 AM test - create failed: Infrastructure creation failed. Reason: No default VPC for this user 
6 REPLIES 6

Re: Cloudbreak 1.4+ Cluster Deployment Fails (No default VPC for this user)

Expert Contributor

Do you have the default vpc in your region ? This is a bug in Cloudbreak. If you don't have default vpc then the provision can not start. This will be fixed in 1.6.0.

The workaround for this issue that create a default vpc in the region.

Sorry for the inconvenience

Re: Cloudbreak 1.4+ Cluster Deployment Fails (No default VPC for this user)

New Contributor

No, we do not have a default VPC and unfortunately I cannot add one. I have tried the rc-1.6 branch of the update but still see the same issue. I also tried 1.8 which produced the same result. Is there a branch that I can upgrade to which will allow this to work?

Thank you for the help!

Re: Cloudbreak 1.4+ Cluster Deployment Fails (No default VPC for this user)

Expert Contributor

https://github.com/sequenceiq/cloudbreak-deployer/tree/rc-1.7 this branch contains the fix. rc-1.6 branch does not contain the fix currently but I will cherry pick the commit.

please type 'cbd update rc-1.7' and after that 'cbd restart' if the problem come up with this branch then we can schedule a webex and investigate the issue more deeply.

Thanks

Richard

Re: Cloudbreak 1.4+ Cluster Deployment Fails (No default VPC for this user)

New Contributor

ok, i will try this! thank you!!

UPDATE: This worked. Thanks!

Re: Cloudbreak 1.4+ Cluster Deployment Fails (No default VPC for this user)

Expert Contributor

happy to hear :)

Re: Cloudbreak 1.4+ Cluster Deployment Fails (No default VPC for this user)

Expert Contributor

Hi @Miguel Lucero,

The fix has been back-ported to 1.6 branch, you can just update with cbd update rc-1.6. The current version is 1.6.1-rc.16 and this issue was fixed.

Please let us know the result.

Attila

Don't have an account?
Coming from Hortonworks? Activate your account here